Go Down

Topic: Hardware robustness... (ADC & RESET)... (Read 10635 times) previous topic - next topic

Vlado

#15
Nov 29, 2010, 05:16 pm Last Edit: Nov 29, 2010, 05:37 pm by slash11 Reason: 1
Thanks PaulNoel for you comments. I have put all the components in to a metal box from a VGA extender, except of coarse the sensors. The sensors connected via shielded cable and are no longer than 0.5 meter. It also runs of the battery, which is in the box iteself and the power line has ferrite ring as you can see on the picture.
http://1.bp.blogspot.com/_JPsb27PGgz4/TPOtOPRztKI/AAAAAAAAF4s/E4L5yDKjzAY/s1600/V+Logger.JPG
The battery is good to hold for many hours and I doubt that its voltage drops below the minimum "browning out" voltage. But that is quite difficult to know.
At my last racing on the track the logger failed miserably, resetting at the rate of 4-5 resets per minute, more at the faster parts of the track.
Now I have made another mod in addition to the ones above. I have cut the PCB line going from PIN 1 of the ATMega see picture to avoid this line acting as an antenna.

http://www.flickr.com/photos/26663689@N08/5217669019/

This mod will make me loose automatic reset during uploading sketches, but I am OK with the manual reset, just time the button press right after the upload begins. ;)
I am going to test it next weekend and let you know the results.

cafo80

#16
Jan 09, 2011, 07:28 pm Last Edit: Jan 09, 2011, 07:28 pm by cafo80 Reason: 1
Hi to all! :)
Like Vlado, i'm developping a board on my kart 125 shifter that cut-off the electric current of engine coil to permit me to shit without close the gas pedal.
And like Vlado, i have the same problem: after few seconds (with the engine on) the arduino resets!
So, reading this post i decide to apply the reset protection.
Quote
Both of these changes are implemented on all of my boards.
http://www.wiblocks.com

1. I use a 10uH, 0.1uF low pass filter.
2. For the reset I have a 1N4148 from the reset pin to Vcc. I also include
  a position of a 0.1uF cap from /RESET to GND. (NB If you use the
  0.1uF from /RESET to GND the /RTS on close reset will not work
  reliably).

(* jcl *)

But i have a trouble with the 0.1uF cap from reset to gnd... After applying the cap the board come into a reset-loop status...
If i apply the cap after the first boot, the sketch start and anything go ok. But if i start the board with the cap mounted on, in this case it appen the condition described...
Any suggestions? Thanks a lot!

Go Up