Pages: 1 [2] 3   Go Down
Author Topic: arduino et EL Wire (débutant)  (Read 1162 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 1
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

alors j'ai chargé le code,

la led 13 sur l'arduino clignote très vite
par contre la led STATUS sur l'escudo ne clignote pas, la carte serait-elle deffectueuse ?

1ère photo : on voit clairement que le el wire s'allume avec un branchement en directe
2ème photo : la led 13 de l'arduino clignote
3ème photo : la led STATUS de l'escudo reste éteinte



Logged


France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3447
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

par contre la led STATUS sur l'escudo ne clignote pas, la carte serait-elle deffectueuse ?
La LED sur l'escudo est connectée directement à une sortie de l'Arduino. Donc si elle ne s'allume pas c'est qu'il y a un problème de câblage de la carte escudo ou un problème de raccordement de celle-ci sur l'Arduino.
Logged

Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

alors j'ai chargé le code,

la led 13 sur l'arduino clignote très vite
par contre la led STATUS sur l'escudo ne clignote pas, la carte serait-elle deffectueuse ?

1ère photo : on voit clairement que le el wire s'allume avec un branchement en directe
2ème photo : la led 13 de l'arduino clignote
3ème photo : la led STATUS de l'escudo reste éteinte

bonjour
la carte est quand meme assez basique
tu l'a achété complete ou c'est toi qui a fais les soudure des connecteurs ?

avec ton symptome led13 ok sur arduino , led10 status non ok sur escudo, ça pourrait venir d'un GND commun deficient entre
la carte et le shield.
fait un test de continuité et verifie que le 5V arrive bien sur le regulateur de l'escudo
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3447
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Comme je ne suis pas très callé en anglais technique, je suis dans le brouillard concernant les branchements de tout le matériel.
Je prends comme base ceci : https://www.sparkfun.com/tutorials/353
il y a plein de points qui ne sont pas clairs

Quand on est pas calé dans une langue, il faut avoir quelques jokers dans sa manche comme Google Translate qui fourni des traductions de qualité relativement correcte lorsqu'il s'agit de passer de l'anglais au français.
http://translate.google.fr/translate?sl=en&tl=fr&js=y&prev=_t&hl=fr&ie=UTF-8&u=https%3A%2F%2Fwww.sparkfun.com%2Ftutorials%2F353&edit-text=
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3447
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

fait un test de continuité et verifie que le 5V arrive bien sur le regulateur de l'escudo
Ne te fais pas avoir Artouste, le régulateur ne sert à rien sur l'escudo. Il n'est utile que lorsqu'on utilise un "inverter" alimenté en 3V.
La diode de status et les optocoupleurs sont pilotés directement par les sorties de l'arduino (connexion entre sortie arduino et masse).
Donc si rien ne fonctionne, il y a de très fortes chances pour que cela vienne d'une masse défectueuse ou de l'escudo mal installé.
Logged

Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

fait un test de continuité et verifie que le 5V arrive bien sur le regulateur de l'escudo
Ne te fais pas avoir Artouste, le régulateur ne sert à rien sur l'escudo. Il n'est utile que lorsqu'on utilise un "inverter" alimenté en 3V.
La diode de status et les optocoupleurs sont pilotés directement par les sorties de l'arduino (connexion entre sortie arduino et masse).
Donc si rien ne fonctionne, il y a de très fortes chances pour que cela vienne d'une masse défectueuse ou de l'escudo mal installé.
bonjour
Fdufnews
oui j'avais vu , mais si tu a du 5V sur regul testé avec le GND de l'escudo ça leve le doute.
mais vu qu'à priori les headers sont a souder , la proba de mauvaises soudures est importante.
ceci etant il y a 2 headers GND bien connecté sur le pcb escudo...  smiley-mr-green

a mon avis , de la reprise faite avec de la bonne soudure s'impose  smiley-cool
« Last Edit: April 29, 2014, 06:20:35 am by Artouste » Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

YOUPI !!!  smiley smiley smiley smiley
j'ai refait les soudures, et du coup le el wire clignote selon le dernier code qui tu as proposé Artouste.
Une pile 9v à été branché sur l'arduino comme ça tout est autonome.
Je vais m'occuper du el wire vert et tout brancher




Logged


Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

YOUPI !!!  smiley smiley smiley smiley
j'ai refait les soudures, et du coup le el wire clignote ...

Bonjour
Erreur de debutant, ne pas verifier ses soudures  smiley-mr-green
Le principal c'est que ce soit finalement "tombé en marche"  smiley-mr-green
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

héhéhé
je cherchais trop loin la solution, finalement c'était tout simple  smiley-roll-sweat
je suis pas trop un pro de la soudure mais je commence à me faire la main  smiley
Logged


Offline Offline
Newbie
*
Karma: 1
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

voilà j'ai branché les deux el wire, un orange et un vert, tout le même code qui fait tout clignoter

http://youtu.be/ZMHIeDw5dtM

c'est une vidéo vite fait avec mon iphone,
Logged


Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

voilà j'ai branché les deux el wire, un orange et un vert, tout le même code qui fait tout clignoter

http://youtu.be/ZMHIeDw5dtM

c'est une vidéo vite fait avec mon iphone,
bonjour
l'effet de lumiere est soutenu
je n'ai jamais utiliser de elwire, mais ça semble sympa
reviens nous faire voir ta realisation , une fois terminée
bon spectacle
Logged

France
Offline Offline
Faraday Member
**
Karma: 36
Posts: 3447
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

YOUPI !!!  smiley smiley smiley smiley
j'ai refait les soudures, et du coup le el wire clignote selon le dernier code qui tu as proposé Artouste.
Sur les photos il y a encore des soudures pas terribles. Sur A0 on a l'impression qu'il n'y a pas de soudure sur une partie de la pastille.
De manière générale tu ne mets pas tout à fait assez de soudure. Normalement la soudure doit remonter le long de la broche.
Logged

Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

YOUPI !!!  smiley smiley smiley smiley
j'ai refait les soudures, et du coup le el wire clignote selon le dernier code qui tu as proposé Artouste.
Sur les photos il y a encore des soudures pas terribles. Sur A0 on a l'impression qu'il n'y a pas de soudure sur une partie de la pastille.
De manière générale tu ne mets pas tout à fait assez de soudure. Normalement la soudure doit remonter le long de la broche.
bonjour Fdufnews
Apprendre à faire des bonnes soudures à toujours été le B A BA du debutant , le probleme aujourd'hui  est aussi que
les "debutants" travaillent souvent sans le savoir avec de la soudure ROHS et des fers basique pas adaptés, avec pour resultats des "mauvaises" soudures.
Je me souviens avoir rencontré IRL un contributeur et quand je lui dis de reprendre des soudures sur un shield, j'ai vu la cata.
j'ai sorti de mon "barda" de la bonne vieille tricore Pb et je lui ai dit d'essayer avec, la difference a été immediate.
perso dans le cadre du DIY , je n'utilise que de la Sn,Pb,Ag et j'ai toujours du flux supplementaire sous le coude (melange perso colophane+isopropanol)
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Apprendre à faire des bonnes soudures à toujours été le B A BA du debutant , le probleme aujourd'hui  est aussi que
les "debutants" travaillent souvent sans le savoir avec de la soudure ROHS et des fers basique pas adaptés, avec pour resultats des "mauvaises" soudures.
Je me souviens avoir rencontré IRL un contributeur et quand je lui dis de reprendre des soudures sur un shield, j'ai vu la cata.
j'ai sorti de mon "barda" de la bonne vieille tricore Pb et je lui ai dit d'essayer avec, la difference a été immediate.
perso dans le cadre du DIY , je n'utilise que de la Sn,Pb,Ag et j'ai toujours du flux supplementaire sous le coude (melange perso colophane+isopropanol)

j'ai pas tout saisi les significations et abréviations  smiley-lol je suis vraiment un débutant primaire, c'est la première fois que je fais de la soudure+électro+arduino+codage.
ci-dessous, deux boitiers de dérivation vissés ensemble avec le matériel à l'intérieur ainsi qu'un harnais de gopro sur lequel je fixerai les boites

Logged


Offline Offline
Faraday Member
**
Karma: 33
Posts: 4986
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

...
ci-dessous, deux boitiers de dérivation vissés ensemble avec le matériel à l'intérieur ainsi qu'un harnais de gopro sur lequel je fixerai les boites
...
[HUM]
j'avais pas vu www.dbr-prod.ch/

Encore un suisse de Gnéév  smiley-mr-green
si j'avais su ...   smiley-mr-green smiley-mr-green

bonne continuation pour la suite de ta realisation  smiley-wink pose le moment venu une petite video de ta prestation avec les El-wire
Logged

Pages: 1 [2] 3   Go Up
Jump to: