Go Down

Topic: shield GSM (Read 565 times) previous topic - next topic

apol

Hello,
I have a problem with the Model R3 shield with GSM Antenna GSM / GPRS on SMA connector developed with Telefonica (http://www.lextronic.fr/P28655-module-shield-gsm.html).
I use a SIM Free and I connected the GSM card to a arduino uno R3. I put the examples given in SendSMS.ino program. I completed the program by entering the 19 digit SIM card (in pinnumber) and in the terminal I have the following messages:
                        SMS Messages Sender
                        not connected
Can I use a SIM free or should we must use a SIM card bluevia?
Thank you for the answer

shanevanj

Quote

I completed the program by entering the 19 digit SIM card (in pinnumber) and in the terminal


The 19digit SIM number is generally not the PIN - this is usually a 4 digit number (supplied with the SIM) that 'unlocks' the SIM and allows it to connect to the network. Contact the SIM provider (or look through the documentation that cam with the SIM) for this pin.

apol

In fact, I've tried everything; I started by putting the 4-digit PIN code of the SIM card free and always the same message "Not connected"
I completed the SendSMS program with the following line of code:
# define pinnumber "2312"
This code corresponds to what I have to go when I turn back the laptop while it was completely off!
Thank you again for the response

davidgoth

Activate debug mode adding 'true' parameter in GSM gsmAccess object. (Ex: gsmAccess(true);). Post your output to help you.

Go Up