Go Down

Topic: Arduino YUN Power Issue (Read 736 times) previous topic - next topic

Hi there,

I have the Arduino YUN incorporated into a project and it has been working pretty well. However, I have run into an issue regarding applying power to the project through the YUN.

If I try to power the YUN from a USB power supply (wall wart) that states that is provides 5.1V at 0.7A, the power light on the board comes on, but a sketch is never started.
However, if I apply power using ICSP (from a USBTinyISP which is how I am uploaded sketches to the YUN) plugged into my computer's USB the board powers up properly and the sketch runs. And if I connect a USB cable directly from my computer to the micro USB  port on the YUN, the board powers up correctly.

So there seems to be an issue when powering the YUN from a power adapter/supply plugged into the wall.  I tried an Apple USB power adapter that I had that is suppose to provide 5.0V at 1A, but that doesn't seem to power the board properly (the power light is lit, but the sketch is never actually run). I also determined that when the Arduino YUN is connected directly to the PC the computer's USB port is providing 500 mA, so a 0.7A wall wart should be providing sufficient amperage.

Of note: When I connect directly to the computer the TX LED is lit (in addition to the power LED) and when I use the ICSP both TX and RX are lit in addition to the power LED. I think most USB wall chargers short the data lines, but I'm not clear on how that might play into the inability to power the YUN from a wall wart (I have now tried 3 different ones).

Additionally, powering with the same wall wart worked two days ago, though I haven't changed any of the set up/wiring.

I think I have demonstrated that the YUN USB power port works and that the board can power up and run properly. However, I really need to be able to power the YUN from an AC outlet and I can't seemed to get that to work. Any thought on why? Additional tests I can do to narrow this down?

Thank you,
Nate

I am facing exactly the same issue. Wall adaptar :5v 1A.
Any ideas?

Regards


Hi,

I have determined, at least in my case, it is not a wall wart or power issue.

I found that I got this issue every time I tried to upload a sketch larger than about 30700 bytes. I don't know the reason, but above that rough value the YUN can run the sketch, but can't reset and run the sketch.  I have removed functionality (LCD) from my sketch so it is small enough to avoid these issues. Removing the bootloader and using the USBTinyISP still gets me an extra ~2000-3000 bytes so its worth it, despite the fact that I can't get a full 32000 bytes.

Nate

mearsy25

Ah Nate Nate Nate my friend.

Your solution to the problem of the temperamental reset button lies here.

I had exactly the same thing so did some digging

http://forum.arduino.cc/index.php?topic=254848.msg1804912#msg1804912

Mearsy,

What a very interesting solution! I'd love to try it, but I'm not sure what fuses I actually need for my application. Can you clarify which fuses you changed to make sure the code jumps to the correct line upon reset.  I also want to ensure that I don't brick the YUN, by setting the fuses incorrectly.

If you can offer any advice I'd appreciate it as I think this is a great solution to this issue and I'd like the ability to use the full 32K of flash.

Thank you,
Nate

mearsy25

Well nate,

I can guarantee on my Yun running on 1.2 firmware that Low 0xFF, High, 0xD1, Extended 0xFB gives me the full 32k to play with and that the reset function works perfectly. as a bonus. those fuse settings done wipe the eeprom on upload. (Like the earlier arduino, eeprom data is preserved). This works nicely if you want to use eeprom to keep data. especially as the new yun 1.4 allows you to field upgrade end users hex firmware. you wouldnt want to lost their eeprom data as part of a firmware upgrade.

I think your most likely to be uploading to the yun via wifi. so the run-avrdue file on the yun needs to be changed. this is the utility which the ide calls on the linino side to flash the actual code to the 32u4 using the gpio pins.

i edited the file using vi and changed the fuses to  Low 0xFF, High, 0xD1, Extended 0xFB

im at work now but will write up some more comprehensive instructions tonight as I need to reamend the run-avrdude on my new 1.4 firmware. obviously every time you upgrade the firmware it restores run-avrdude back to its defaults.


Mearsy,

Great. Thanks for that clarification. I have the updated firmware to 1.4 as well, but I have been uploading using a USBTinyISP. I created a new board in the board.txt file with the larger memory size and set to upload using USBTinyISP.  I'll explore again how to reset the fuses, but if you have time to write up some comprehensive instructions at some point I'd be very interested as would a number of others as well.

Thanks for your help,
Nate

Go Up