Go Down

Topic: Arduino Ethernet Shield (Read 11 times) previous topic - next topic

crayderfish

Quote
I just updated the Ethernet shield project note -
http://www.nuelectronics.com/estore/index.php?main_page=project_eth

and included an example of switching on/off a LED via webserver.

It might be helpful for your project.


I think the Arduino Ethernet Shield of Nuelectronics is very useful for the most engineers.  :)
The Xport of Lantronix is very poweful but it is too expensive for me.  :-[
Is it possible to integrate the Ethernut 2 into the Arduino as the Shield?  8-)


nuelectronics

I've developed a example of howto use the ethernet shield as a web client.  I think it is useful, as the ethernet shield can be used as a distributed network sensor.   :)

Better start a new topic on this, so there is the list on Arduino forum http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1219733115, or you can visit my blog at http://www.nuelectronics.com/estore/?p=14.

Luca

I just purchased this Ethershield from nuelectronics and I can't wait to get started.
Unfortunately I am kind of new at this Arduino thing and I am having hard time getting started with the library.
I downloaded the library and the examples but what I really need now is a description of the keywords and parameters.

Does anyone know where I can find them?

Thanks


exilepc

how could i make this work on the arduino ethernet shield?

caquino

HI,
I'm having one little trouble with the ethernet shield.

I'm trying to use the examples included with the library, in arduino 0016 and 0017 and are not working.

The ethernet links in 10mbits half duplex but I can't see nothing being transfered, even arp.

The board in not listed in the arp command, and does not pass arp packets in the wireshark.

I tryed too to use one cross cable direct to the PC, straight cable, plug in a Switch, HUB, and does not work. I get only sometimes the link yellow light and nothing else.

I have added some debug in the code printing to the serial port, and everything looks fine, I do not have another mac address or ip in conflict in my network.

Someone have any idea to help one poor soul?

Thanks in advance

Sourcery

Caquino: Using the Arduino as a server (example code), that just shows the values of the analog ports on a webpage:

1. what ip-range does your network run on? eg. what is your Gateway IP, and the IP of your connected machines? What subnet mask are you using?

2. Make sure that you have an ipaddress on the Arduino in the same ip-range that your network runs on, but NOT a conflicting address with any of the computers (or other equipment) attached.

3. From one of your computers connected to the same network as the Arduino, surf to the IP-address that you programmed into the Arduino Code. This should give you a page with the values of the analog pins.

If it doesnt work, reply with more info...

/Kristian

caquino

Hi Sourcery,

My network is runing in the 192.168.1.0/24 range, my gateway is 192.168.1.1 and the machine that is accting as the client is the ip 192.168.1.9, my netmask is 255.255.255.0 (/24)

The ips are in the same subnet without conflict.

I have tryed both client and server example, using this network that I have described, and using only one cross cable direct to my machine.

Runing wireshark/tcpdump in the machine I can't get any packets from arduino, even arp requests/replys.

Thanks in advance

Sourcery

Hello again,

What IP have you given the Arduino? I think if you give the arduino an ip like 192.168.1.25 and then just connect it to your switch/router/hub with a normal TP-cable. Use the sketch I mentioned before and surf from your client (192.168.1.9) to 192.168.1.25 you should get a white page with the analog pin values... No?

You dont need to check with wireshark/tcpdump stuff yet... (not sure the Arduino sends any info without interaction)

/Kristian

caquino

My arduino is on the same subnet 192.168.1.15, I have tryed the normal cable to one switch and to one hub..both failed... after tryed to connect direct to my machine using cross cable, changing the network data to one network between my pc and the arduino, and does not work too..

Runing tcpdump/wireshark in my pc and in my router I can't see any packets coming from the arduino, neither arp packets.

The switch does not see the mac address of the arduino.

I have tryed the ping sketch, web client and web server, trying to access the arduino, without sucess.

Thanks again

Sourcery

How do you mean fail to connect to the hub and switch? Does anything light up on the switch/hub? If you get the link led, then you are connected correctly. If not, its usually something in the physical layer, eg:
1. Faulty cable
2. Faulty port (on switch/hub or arduino)
3. Faulty Ethernet shield

But if you DO get a link led light, then it is probably something in the software or setup...

So link or no link? :)

/Kristian

caquino

The link goes up for some seconds (the arduino and the endpoint lights up), and after some seconds goes down.

I think this is not normal, I think I'll ask for a replacement shield.

The cable and the switch port is ok, I tryed in another computer and worked fine.


Sourcery

I agree. You should try with another shield...

Get back when you have tried with the new one...

caquino

Unfortunately or fortunately I found the problem.

Actually is not the shield, but my arduino, when it's powered by the USB the ethernet shield does not work, using a external power adapter the shield works fine.

Sourcery

Hello Caquino,

Thanks for getting back with what the problem is, good to know for future bug searching...

So the probem is that your arduino doesnt send out enough current from the internal power supply/converter? If it is used when using USB? Old computer? USB1.1 (is it different?)? Ground problems from the computer?

Thanks again,

/Kristian

caquino

Hi,

I have tryed in several different computers and USB cables just to be sure.

The computer is a macbook pro, so I don't think this is the problem, I'm trying to figure out if the maker of my arduino have changed something from the official design.

Thanks

Go Up