Go Down

Topic: Arduino-izing the AVR Butterfly (Read 22142 times) previous topic - next topic

Nick Lott

I've removed the two transistors and soldered directly to the pads on the butterfly before, but unless you've done a lot of surface mount work probably not for the faint hearted.


also check this link it is discussed here i think. http://dorkbotpdx.org/blog/feurig/dorkbotpdx_arduino_programmer


Been a long time since I was on this thread, but I just broke out the butterflies.  I don't suppose anyone is hosting the latest and great arduino butterfly bootloader HEX files?

here's the most recent one I found, but it doesn't sound like he's picked up all your changes (or even using the same SVN tree)


Nick Lott

Mar 23, 2010, 05:47 pm Last Edit: Mar 23, 2010, 05:55 pm by Brokentoaster Reason: 1
You should be able to use the standard butterfly bootloader.
so long as you setup the arduino software boards.txt file with the following entry
Code: [Select]




Also check out this link http://code.google.com/p/butteruino/


Mar 26, 2010, 02:29 am Last Edit: Mar 26, 2010, 02:29 am by creatrope Reason: 1
I've grabbed the latest code using TortoiseSVN under Arduino-0018.

I'm getting WProgram.h: no such file or direction in function void setup() for all example programs.

I have the files under arduino-0018/hardware/butterino/cores/arduino. WProgram.h is there and this directory structure is symmetric with a working Sanguino structure, file by file.

I've tried moving things around a bit to see if it locates the file.

Can someone verify a compile of the latest example programs under Arduino-0018 for the Butterfly?

thanks - creatrope

Mark S

I got blink to compile under 0018 on the Mac

I downloaded the butterfly files from

I put the folder in

I deleted everything except the butterfly entry in boards.txt

I had to make these changes

    rename main.cxx to main.cpp

    add #include <WProgram.h> to main.cpp

I do not have a butterfly to check out to see if it works.

I tried compiling a couple of programs, anything that used TWI (I2C) does not compile.



Ok, compile problem resolved.

I've set bfly.upload.using=butterfly in the boards.txt
(also tried in preferences.txt)

Verified UART connection is working by entering 'name' via freshly loaded stock butterfly firmware.

I tried various combinations of pressing the button, resetting and uploading.

Upload eventually times out with:

Connecting to programmer: .
Found programmer: Id = ""; type =
avrdude: error: buffered memory access not supported. Maybe it isn't
a butterfly/AVR109 but a AVR910 device?

The sequence of start the upload and pressing the button - anyone have a recommendation for a known sequence/timing that works reliably?


Nick Lott

I normally go for tapping the button and then start the download while tapping the whole time.

Although I haven't tried this for a while.


Oct 28, 2010, 01:54 pm Last Edit: Oct 28, 2010, 01:55 pm by sathopper Reason: 1
fortunality all the links to the arduino012_butterfly.zip file are broken.
Where can I download this file or can someone email the file (email button)

Thanks  ;)

Nick Lott

Sorry I've had my website compromised. I had to clean out some files. The new link should be.


I haven't looked at this project for a while... so no promises that things still work.  :)

Good luck.


I have a butterfly laying around on my desk for quite a while maybe now  I can do some funny stuff with it.  :)

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131