Pages: [1]   Go Down
Author Topic: standalone board problems  (Read 820 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
I love YaBB 1G - SP1!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I'm having problems getting the standalone board to work. I've done a bunch of things so it's complicated to narrow down exactly where the issue is but I'll just go through what I've done and hopefully someone might have an idea.

First of all - a couple of things with the instructions and software that are causing confusion or problems:

- There's appears to be an inconsistency between the schematic and the picture of the assembled board. In the schemtic it shows pin 2 of the AVR connected to pin 1 of the hex inverter, but in the picture it's connected to pin 2 of the hex inverter. (I assumed the shematic is correct but I've tried it various ways during the course of my fiddling)

- The burn.command script didn't work for me. It successfully completed the first couple of commands but when it got to the upload instruction is gave an error (I think it was "Unable to enter progam mode"). On the PC it got nowhere.

Here's the basic saga. Note that I've tried some stuff on both the PC and Mac (including the Arduino0003 software), so sometimes the ordering here is not exact.

- First I uploaded the bootloader manually with AVR Studio with the STK500.

- Tried to connect to the Arduino0003 software but got "Programmer is not responding" error (Mac and PC). However the light did blink the LED on reset indicating that at least the bootloader seemed to exist on the chip.

- Realized that I needed to run that script that sets the fuses as well uploading the bootloader so tried that. With PC first I think, which did nothing (i.e. hung on the first command). Tried it with Mac (OS 10.4.4) which where I go the error I describe above. At this point the chip no longer had the bootloader program (at least it didn't seem to since it didn't blink the LED anymore).

- After managing to the the chip reset, I tried loading the bootloader manually again and now there's further weirdness. It seems to function as before on the programmer (i.e. it appears to be in external clock mode and have the bootloader), on the breadboard the LED blinks slower than before and even blinks if you remove the clock (but not the capacitors).

At any rate, at all points I would get a "Progammer is not responding" error in the Arduino0003 software.

Any ideas?

Thanks,
Damon
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What clock/crystal/oscillator are you using?  The burn.command script sets the fuses for use with a 16 MHz external oscillator, as on the Arduino board.  If you've got a different setup it will give you problems.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
I love YaBB 1G - SP1!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, it's 16 MHz - the Digikey part #300-6034-ND that is listed in the parts list.

Thanks,
Damon
Logged

Pages: [1]   Go Up
Jump to: