Go Down

Topic: upload error on intel mac (Read 605 times) previous topic - next topic

nonverbla

Hello,


I'm really a beginner in using the Arduino Board, and have a very important question:
I wrote a little code for the board and want to upload it to the board on Mac OS X (the machine is an Intel-based Mac :P).
but when I try this, an error occures:

»Binary sketch size: 5910 bytes (of a 7168 byte maximum)

Programmer is not responding. RESET the board right before exporting«

I tryed it in Windows and everything worked well. So I uploaded the code on Windows and now I use it in MAC OSX, and processing gets every data over the port »/dev/tty.usbserial-0000101D«
I don't want to restart my Computer every time I have to upload my Code, how can I fix this Problem?

Thanks for your help, Rasso

admin

Arduino 4 has some parts that are not Intel native but are still compiled for the PPC. this means that when you press the upload button it takes much more than the usual 5 seconds to prepare the file and initiate the upload.

there is a simple cure for this (until one of us gets and intel mac and make a specific version)

when you press the upload button then press the reset button on the arduino and keep it pressed for about 6 seconds then let go and the code should upload normally.... it's just to compensate for the longer processing time due to the ppc to intel translation


massimo

nonverbla

WOW, thank you very much! it works great.

greetings, Rasso

Marcosz

hello.

i am having the same problem like Rasso, only that i am not using an intel mac, but a titanium powerbook with osx 10.4.6. i also tried to upload with a 12" powerbook and the same OS. On both computers i am getting the "Programmer is not responding" error. I tried several things like pressing the reset button earlier and longer or changing the baud rate from 19200 to 9600 but nothing seems to work.
I am using an usb arduino board with tx/rx leds and serial number.

Any idea, what i can do? It's probably just a small thing, but I am not getting it...

Marcosz

mellis

Did you check the FAQ?
http://www.arduino.cc/en/Main/FAQ

Marcosz

#5
Jul 08, 2006, 04:54 pm Last Edit: Jul 08, 2006, 05:17 pm by Marcosz Reason: 1
yes, read the faq und tried everything like change baud rate (also via the preferences.txt). i found other threads in here dealing with this problem, too. but obviously not the right solution.

what i do: i open the ide and load led_blink. i press the reset button on the board and as soon as i release, i click upload. the tx led on my board will then blink orange for once. then i get the "programmer is not responding"

is there a way to find out the bootloader version? and the firmware version of the board?

nonverbla

Quote
when you press the upload button then press the reset button on the arduino and keep it pressed for about 6 seconds then let go and the code should upload normally....


You have to press the upload-button FIRST, than press the reset-button on the board for 5-6 seconds. maybe you have to find out the right length to press the reset-button for your OS.

Marcosz

#7
Jul 10, 2006, 10:54 am Last Edit: Jul 10, 2006, 11:21 am by Marcosz Reason: 1
I tried this too and tried to vary with the intervall between resetting and uploading (or the other way round). In fact, I did not make any progress so far.
I got my old pc up and running to test the board but got the same result:
"programmer is not responding".
I am running out of ideas, what I could do more...
Any idea anyone?


However, I do get a different error message at 14400 bauds ( in the preferences.txt) it says: invalid speed then...


Go Up