Pages: [1]   Go Down
Author Topic: Arduino on Linux FC5: gui errors!  (Read 616 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

I am really excited to use this board but i can't get it up and running. I get the happy green light and /sev/ttyUSB0 shows up when I plug in the board, but...

First my system:
AMD64 laptop running Fedora Core 5 in i386 mode
My kernel is 2.6.16-1.2080.13.rrt.rhfc5.ccrma #1 PREEMPT

I followed the directions here to get avr-gcc and other tools installed (not that i am exactly with avr-gcc is compaired to regular gcc).
Also I added DIRAVR=/usr/local (as all the tools are in /usr/local/bin) and CLASSPATH=/usr/java/jre1.5.0_07/bin:/usr/java/jre1.5.0_07/lib/rt.jar

I downloaded the arduino IDE via svn and built it (and got a bunch of messages that looked like warnings about non-determinant values).

Now I run the run.sh script and I get a file dialog but no files are listed (even though the all files (*.*) selector is selected).
Moreover, when I try to specify the file explicitly within the dialog a directory structure is created within the work directory. For example if my "sketch" is /home/wade/Pd_firmware.pde a directory is created /home/wade/trunk/build/linux/work/null/home/wade/Pd_firmware.pde/

Is there a way to debug this gui so I can see where things are breaking down?
I am so excited to use this board I think I am gonna wet myself!!!

Thanks everyone for the help!
-thewade
Logged

Pages: [1]   Go Up
Jump to: