Go Down

Topic: gsmAccess.begin() problem (Read 3811 times) previous topic - next topic

simone rey

Often, the sketch stop on "gsmAccess.begin(PINNUMBER)" instruction... But if I make the phone call rings so there is no network problem. Library problems??? Help me. Thank You.

Simone

DAHANS

I have the same problem, I try to unite everybody who has this problem to the same post, so we can search together for a solution.

http://forum.arduino.cc/index.php?topic=247184.0
"DO I DETECT A NOTE OF UNSEASONAL GRUMPINESS? said Death. NO SUGAR PIGGYWIGGY FOR YOU, ALBERT."
? Terry Pratchett, Hogfather

davidgoth

Replace line "GSM gsmAccess();" with "GSM gsmAccess(true);" to activate debug mode.

DAHANS

This will only print out the AT-Commands, the Problem will still occur, and the Output will be CREG: 0,2 or something like this, the problem is that the GSM library doesn't have a catch or something for this case so it won't return anything, neither GSM_READY nor ERROR or anything, thus crashing the whole sketch without being stopped.
"DO I DETECT A NOTE OF UNSEASONAL GRUMPINESS? said Death. NO SUGAR PIGGYWIGGY FOR YOU, ALBERT."
? Terry Pratchett, Hogfather

lhanly

I am having what appears to be the same problem. I have tried two different SIM's, one being the Telefonica M2M which came with the Shield and the other another data SIM tested in another product.

Its a new Shield which I received today and I have tried several of the sample projects.

The gsmAccess.begin never returns and hangs, I am Monitoring the serial port, only once and last message received:
"GSM networks while not Connected" :~


// Default no SIM
// Start GSM shield
  // If your SIM has PIN, pass it as a parameter of begin() in quotes
  while(notConnected)
  {
    Serial.println("GSM networks while not Connected");
    if(gsmAccess.begin(PINNUMBER)==GSM_READY)
      notConnected = false;
    else
    {
      Serial.println("Not connected");
      delay(3000);
    }

I have a similar problem in the example's SendSMS sketch. I have a SIM900 with Mega and I have configured by bending pin 2 and using a jumper between pins 2 and 10.
However, it gets stuck at " gsmAccess.begin(PINNUMBER) " line of the code. When I enabled debugging on gsmAccess, the serial monitor shows "AT%13%".
Does anyone have any suggestions that I could try to solve this?

lhanly

Hello,

I still cannot get this resolved, just wondering did anyone else make any progress on this?

Regards,
Lewis

Go Up