Pages: [1] 2   Go Down
Author Topic: avrisp mkii  (Read 2261 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
I love YaBB 1G - SP1!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Has anyone had any success using AVRISP mkii on Mac OS X to burn the Arduino bootloader? Is it possible? I can't find any mention of drivers for Mac and it doesn't show up in /dev so I don't know how to address it in the burn script.

Thanks,
Damon

P.S. I'm having similar problems attempting it on PC, but I have no idea what I'm doing on PC anyway.
« Last Edit: April 08, 2006, 01:23:08 pm by drh » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
I love YaBB 1G - SP1!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

OK, I finally got the bootloader to burn using avrdude instead of the burn script in the Arduino package. I have to run off, but I'll post detailed instructions later since it may be helpful to others.

Damon
« Last Edit: April 08, 2006, 03:29:48 pm by drh » Logged

New York, NY, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 40
Howdy. I don't check PMs often, so email me!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Please do post your results. I haven't had any luck getting the AVRISP Mk II (USB version) working on my mac yet.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 37
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey, I'd also be pretty interested in how you got the avrisp mkii working with the mac...

here's what I got so far: I'm running Tiger and installed libusb from darwinports. When I tried to also install avrdude that way, darwinports complained about mismatching md5 sums, so I downloaded avrdude 5.1 from the official archive and built it manually, linking against the libusb from darwinports (libusb support is definitely compiled in now since I can see it's loading libusb dynamically (one can check using 'otool')).

anyways, when I pass '-P usb' to avrdude, it says

avrdude: usbdev_open(): did not find any USB device "usb"

even though the avrisp2 is connected to USB, the plug is connected to the Arduino board and the board is powered externally from a wall wart. I managed to upload the new 1k bootloader to my boards using avrstudio on windows, but I would greatly prefer to get it working on the mac...

please please post how you got it working  smiley-wink
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am running on 10.4 and compiling everything (avrdude, gcc, libusb) myself worked well.

There is kind of a good intro here:
http://www.eecs.berkeley.edu/~mseeman/resources/macmicro.html#serial

The AVRISP mk II also works without any problems using the -P usb option.

-mj

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 37
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the info, unfortunately, it doesn't work for me yet.

Which versions of avrdude/libusb did you download (I doubt gcc plays a role here), the most recent stable versions or did you check out their cvs?

Are you on an Intel or PPC Mac?

Also, did you have to change any permissions somewhere (like in /dev, for example) and are you working as superuser or with sudo, as user with administrator privileges or a normal user?

Sorry for bothering you with even more questions, I just really want to get this to work.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

These are the packages that I am using:
arduino-0004
avr-libc-1.4.4
avrdude-5.1
binutils-2.16.1
gcc-3.4.3
libusb-0.1.12
serproxy-0.1.3-3  

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

And here is the avrdude script to upload the bootloader to Arduino. Works from the bootloader directory.

# Initialize Arduino board with boot loader
CMD="/usr/local/bin/avrdude"
OPTS="-p m8 -b 115200 -P usb -c avrispmkII"

# Erase chip write lock and fuses
$CMD $OPTS -e -U lock:w:0x3f:m -U lfuse:w:0xdf:m -U hfuse:w:0xca:m

# Upload bootloader code
$CMD $OPTS -D -U flash:w:ATmegaBOOT.hex:i

# Lock boot section
$CMD $OPTS -U lock:w:0x0f:m
                                                                                                                                          
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh I missed the questions:

I am on an old 12" G4 Powerbook on OS X 10.4.6

I do have the Development tools installed. Because I also want to write code for the board in C, I have build the whole toolchain including the avr-gcc and serialproxy etc.

I used sudo only to install (make install). I also did not change the target so everything got build for /usr/local. I did not have any problems compiling and installing.

-mj
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 37
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for answering my questions, I'll give it another shot this evening and keep you updated on the results. Also thanks for posting the bootloader burning script using avrdude, that saves me some fiddling as well!

One more thing though, did you change anything in avrdude.conf from the default one that gets installed during "make install"?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nope I did not change the config file.

I presumed that avrdude is looking for the config file in the home directory and there is none. All options necessary should be given on the command line.

-mj
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 37
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Awesome, I rebuilt libusb 0.1.12 and avrdude 5.1 from scratch, it works now using your burning script! Thank you very much for your help!

Maybe an administrator should link this thread into the FAQ section of the official website?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You are very welcome!
Logged

Forum Administrator
Offline Offline
Newbie
*****
Karma: 3
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would happily link this thread but wouldn't it be amazing if one of you wrote a little summary of the procedure and post it on the playground? smiley smiley smiley

sometimes forum threads are a bit confusing for beginners but they are a great way to collaboratively reach a solution.


any takers?

massimo
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 14
I Love YaBB 2!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can do it. As soon as I have a littel spare time.

-mj
Logged

Pages: [1] 2   Go Up
Jump to: