Go Down

Topic: wifi dont work (almost) (Read 772 times) previous topic - next topic

sulf

Hi, I have a big big problem. In order to improve my system I add a sensor "made in house". A 220v relay with a 1k resistor connect to gnd and before the resistor a wire plugged in yun pin10. Tested it works with the pin13 led. Then I write sketch to send sensor value to http://arduinoip/arduino/status/1. It worked, then i make my android app get the value and it worked. Everything was perfect on the day when... I realized that when i send one order to arduino, in a few seconds my phone lost wifi connection. And never find again until I poweroff-poweron the board. Sometimes i can make two orders sometimes one only but always finnish with the wifi interface down. I reset the board (wifi rst 30+ seconds) but its still malfunctionning. Some idea why is this happen? I have two yuns and all makes the same. Maybe my sensor was wrong and burn the board? Not sure, because wifi works. My sketch and android app arent the problem. I reverse to previous version and yun is still failing. And the last reason is that the wifi fail occurs when i get my browser go to http://ip/arduino/some/order (same that my app do). May i have to buy another yun? Of course i wont plug the sensor :) Maybe is overheated the reason why wifi is failing? I have no more ideas.

Greetings and sorry about my poor english.

Federico Fissore

I'm not sure I got it: your yun is in access point mode and your phone loses connection with wifi "arduino yun xyz" ?
Have you upgraded the Yún? If you've just got it, then ***it needs to be upgraded!*** Check out the tutorial at http://is.gd/1jUPNF

sulf

#2
Jun 17, 2014, 12:00 am Last Edit: Jun 17, 2014, 12:02 am by sulf Reason: 1
yes it is in ap mode and my phone doesnt lost the connection, the yun interface go down. Making test-error I get the problem but i dont know why. I have a 4 relay board. I have two output pin that works perfect. With home made sensor also works but the third pin connected to 3 relay make wifi crash. I try with all connected and I comment the three sentences in my sketch refering to that port and dont crash. The third relay is first relay negative, example of my code is:
digitalWrite(11, high); digitalWrite(10, high);  or digitalWrite(11, low); digitalWrite(10, low);  The 11 sentences works but the 10's not. I lie, yes it works my relay led light up but wifi crashes. More debugging i cant do! The last idea i had is that from +5v pin I power 220v relay and the 4relay board with the same wire (one wire two connectors I made) I think that it wouldnt be the problem but  now is the only thing i see that may cause wifi crash...

PS: I also have tested from pin 10 to 6, changing the wire and plugging in the forth relay (The one that is empty)

Federico Fissore

Could it be a power issue? Maybe your project is draining too much current from the yun?
Have you upgraded the Yún? If you've just got it, then ***it needs to be upgraded!*** Check out the tutorial at http://is.gd/1jUPNF

sulf

Yes, 30 minutes before reading of the draft order of career I solved the issue. I was powering yun with a 220v to usb converter that output 1A. Now I change the supply with one that output 2A and it worked!!

Thank you!

Go Up