Go Down

Topic: arduino BT newbie need help!!!! (Read 796 times) previous topic - next topic

yerg2k

Hello.

I initially had issues with timing, but now I release my mouse pointer (on the upload button) at the same time as the reset button. Actually, starting the upload process on the pc slightly before sometimes helps on slower PC's, IME. I'm not sure if the arduino program compiles the sketch each time after clicking "upload", so this could change the window for uploading.

Daniel

#5
Mar 29, 2007, 04:46 pm Last Edit: Mar 29, 2007, 04:47 pm by Daniel Reason: 1
hi

quite often people think there is something wrong with Arduino Hardware, when it is really very rarely the case...
My university was kind enough to purchase 35 BT boards for a class I am teaching. While they have worked very well for the most part,   I have had some problems, including the one you mention (which was solved by re-associating the board in the preferences on Mac 10.4.9). I haven't had a problem yet that could not be solved by re-associating the board, or, in a few cases, uploading the bootlaoder again.

D

mungbean

#4
Mar 29, 2007, 03:15 pm Last Edit: Mar 29, 2007, 03:21 pm by mungbean Reason: 1
I'm still waiting for clarification from Massimo on this, but the bottom
line seems to be that there may be some timing issues with some BT boards...  

I've had problems with my board when trying to program
it on an Intel Macbook Pro with built-in bluetooth, and with a G4/PPC eMac
and a WinXP machine both using the same MSI BT dongle.   On all these
systems the problem is that sometimes the burn process doesn't
work and I see:

Atmel AVR ATmega168 is found.
Uploading: flash
Firmware Version: 1.15
Firmware Version: 1.15


but followed immediately by

Programmer is not responding.    

Sometimes I just get the last line.  The problem comes and goes, but
programming is never 100% reliable.  I tried both v0006 and v0007,
but saw the same problem.

See also this thread: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1172165360

If anyone can bring us up to date on the situation I'd be very grateful.  
I'm wondering whether to return my board for a refund, because I can't
use it as it is.


Daniel

hi

have you selected "atmega 168" in the Tools>Microcontroller menu?

D

bigbrueder

I have the same problem here.

I am using Windows (Vista) and a MSI Bluetooth-Dongle.
Dongle is working finde..no problems connection to mobiles etc.

I have Arduino 0007 running, switches SerialPort to the COM Port given by the Dongle (COM4)
and also switched the MUC to ATmega168.

The Problem is, as above, that i can't upload anything to the board.

I am trying to upload the standard "Blinking LED" Sketchbook to it
but i allways get the "programmer is not responding" message.

Is there anything I can do to make it work?

Go Up