Go Down

Topic: 2560 slow compiling (Read 859 times) previous topic - next topic

bernieaw

This is the sketch I am running.  It takes about a minute to compile, then it fails to upload. It will eventually upload after about 4 attempts.
int LED = 13;
void setup()
{
  pinMode(LED,OUTPUT);
 
}
void loop()
{
  digitalWrite(LED,HIGH);
  delay(100);
  digitalWrite(LED,LOW);
  delay(1000);
}

HugoPT

If you are using windows did you already tried to stop the anti virus protection?
When I use Windows I need to shutdown the Kaspersky because it cause a very slow compile.It's because it have a true Prevent feature that monitor all activity.
Of course it could be another problem ...
Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B

bernieaw

Hi Thanks for your reply.
I disabled all my antivirus and firewall settings, and it compiled ok for a few minutes then went back to running very slowly again. I'm very puzzled!!???

eried

Several people report this issue time to time. If you set TeamViewer in your machine and send me the ID and pass via private message I can try to solve your problem and discover the root.
My website: http://ried.cl

eried

OK it was some security solution interfering after all. Hey bernieaw can you post the picture I left for you? I didn't saved it. But it will be useful for other guys with the same problem.
My website: http://ried.cl

rholt

:0 bringing down Kaspersky made the difference for me. worked fine @ home but not here @ work where we have Kaspersky Running.
for HugoPT - sometimes when u shut down an AV, it will only shut down for a specified number of minutes and then turn the AV back on again... this is for safety. I will see if there's a workaround in order to allow this program to run uninhibited.

Russ from Coral Springs, Fl  8)
Russ from Coral Springs, Fl, USA

Go Up