Go Down

Topic: Drivers won't install, board doesn't work (Read 1 time) previous topic - next topic

st33d

I've just bought an Arduino Diecimila.

Upon plugging it in Windows XP popped some bubble saying it stated it was a FT232R USB UART and then did nothing. I've tried to use the Hardware Wizard but I've no idea what it's guessed the Arduino Board to be because nothing on there suggests a microcontroller so I can't follow the steps in the Guide.

I've tried to run the blinking lights demo regardless and got this result:
Code: [Select]

Binary sketch size: 1108 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

and no effect on the board.

I've even gone through the route of trying to install a device that isn't on the list and when I navigate to the FTDI folder it refuses to display any devices. It displayed a device for the other folder (AVRISP) and I installed that and that doesn't work either.

Help!

mellis

What did you tell the Add Hardware Wizard?

You might need to uninstall the drivers and try it again.  Do you see the FTDI device in the device manager when the board is connected?

st33d

There is no FTDI in the harware list. The Add Harware Wizard never popped up when I plugged it in. When I launch the Add Harware Wizard from the Control Panel it just gives me a list of the harware I already know about. The light on the board flashes and everything, but not once a second like the demo code would have it do.

Cheater

Try rebooting and then plugging it in to a different usb port.

ladyada

#4
Sep 20, 2007, 10:04 pm Last Edit: Sep 20, 2007, 10:05 pm by ladyada Reason: 1
this has happened to me before :(

use FTclean
http://www.ftdichip.com/Resources/Utilities.htm
it will clean out the FTDI drivers and you should start again from the beginning
make sure to click "yes" three times, as it's a little tricky to keep people from accidentally using it. just read the dialog boxes very carefully!

 limor

st33d

It doesn't give me the hardware wizard after I use FTclean or use a different port or restart the system. It just says that there's the device there and says that it can see a usb serial converter and a serial com port in the usual bottom right bubbles. Then it does nothing. And I still get the same error if I try to upload.

What device am I looking for in the Device Manager? And is there an executable I can get to put these drivers in at all? It's clear that my computer clearly thinks it knows what the device is and doesn't care to update or even install it. I've pointing the hardware wizard at the FTDI folder with the COM port and USB port that appear in the Device Manager and that doesn't work either.

ladyada

#6
Sep 21, 2007, 04:39 am Last Edit: Sep 21, 2007, 04:40 am by ladyada Reason: 1
http://www.ladyada.net/learn/arduino/lesson0-win.html

shows what the device should look like if it appears

do you see a USB serial device in the Device Manager?

thunderbirdje

Hi st33d,

Same situation here...

Till yesterday everything was working fine (and the driver appeared like ladyada says).

Yesterday I played with the example code from KOPF Gmbh (http://www.ftdichip.com/Projects/CodeExamples/CSharp.htm)...

That application allows you to write en read to? the FTDI-chip.

Since yesterday my Arduino isn't regonized anymore :(

I don't know if it's possible to change the FTDI-chip setting? Or maybe I did it with the example application?

mellis

Hi thunderbirdje,

The examples you linked to use the D2XX drivers for the FTDI chip, while Arduino uses the VCP ones.  Did you install the D2XX drivers?  If so, that's probably why your board is no longer recognized by the Arduino software.  You'll probably need to uninstall them and install the VCP drivers instead.  

thunderbirdje

Hi Mellis

That's correct. I did try to install the VCP-drivers serveral times with no succes.

Then I connected my board on a pc (where nothing was changed) and windows recognized mij board as "USB Serial Converter" instead of FT232TL USB UART.

Could it be because I used the above application en did some EE_READ en EE_WRITE? Is the FTDI-chip (pre-) programmed (with some instruction?) on the Arduino board? If it is, is it possible the program then back in the factory settings? I do hope so :$




mellis

Hmm, if you've changed some of the EEPROM settings of the FTDI chip, I'm not really sure what to recommend.  I haven't messed with them myself, but I'm pretty sure that the boards ship with the factory default settings for the FTDI chip, so if you can get your software to restore those, you should be okay.  I think FTDI provides a Windows program to adjust those settings.  

thunderbirdje

Hi mellis

Indeed. There is a little program MProg (http://www.ftdichip.com/Resources/Utilities/MProg3.0_Setup.exe) which is able to read/write the EEPROM settings.

I already tried the 'default' settings with no succes.

Do you or do you know someone who has a Arduino NG Board (rev C). I would be so happy if someone would "read" (not write of course) the settings from the FTDI chips (you can save it) and maybe post it to this thread?  ;D

Thanks a lot!

Go Up