Pages: [1]   Go Down
Author Topic: Error on upload sketch  (Read 1710 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

First of all, sorry for my bad english. I yesterday get a arduino board, upload the sample ASCIITable (that sends ASCII code to the PC) and it all worked fine. Now my board always gives the error

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Anyone have some tips about this? Could it be that the ASCIITable program is sending data trough serial interface? Can I clear that program? How?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The ASCII Table program shouldn't be a problem.

Did you check the troubleshooting guide: http://www.arduino.cc/en/Guide/Troubleshooting#upload

What board and operating system are you using?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Im using an Diecimilla board and tried on XP SP3 (worked the first time), on Vista 64bits and on Vista 32bits. The only one that worked the first time was XP (now all machines gives the same error). The ASCIITable application is still working (I can see through the "serial monitor" the data. But am not able to upload a new sketch. When I try to do it, the RX led blink 3 times and then, after a moment (15 secs), i receive the error. I read several posts about this error, but (like many other people) still unable to resolve the problem. What could be causing that problem to so many users?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I follow all instructions on http://www.arduino.cc/en/Guide/Troubleshooting#upload page. Can't imagine nothing more except buy another board. But exist so many people with this problem (just search google for the error message) that I am afraid. There must be SOMETHING that cause this (sadly, I lack the tecnical skills to discover it). Maybe a component malfunction. I just want to understand, so I can take more care. I didn't even connected nothing (except usb cable) on my board, and isn't working anymore. All I did was upload the ASCIITable example. After I disconnected the board from the USB, I tried it on a Vista machine, and after that, my problems begin.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

there is another thread on this same error topic - see "Can't upload sketch!"
There are many of us with the same problem. There are also some suggestions there - I think the suggestion on reloading the bootstrap program may be worth trying...
Logged

Central Indiana, USA
Offline Offline
Full Member
***
Karma: 0
Posts: 202
So many projects, so little time...and money!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Obscur3,

I posted my solution on the thread "Can't upload sketch!".  I had to change the com port when using the USB board.  The software does not seem to automatically set all of the settings when you plug in your board.  I changed my com port from com1 to com5 and mine started working.
Logged

Pages: [1]   Go Up
Jump to: