Go Down

Topic: Arduino midi drums, midi issue...... (Read 747 times) previous topic - next topic

sopnil567

I am very new to Arduino. Upload the program in my Mega 2560 board.
i have copy the sketch from here
www.spikenzielabs.com/Downloadables/DrumKitV1b.pde.zip

i have change these Code:

Serial.print(status);
  Serial.print(PITCH);
  Serial.print(VELOCITY);

to this:Code:

Serial.write(status);
  Serial.write(PITCH);
  Serial.write(VELOCITY);


after running the program when i hit on piezo disk  hairless-midiserial shows

Serial In: Ch 9:  note%2 on velocity%3
Serial In: Ch 1: Pitch bend 15384
warning: got a status byte when we were expecting 2 more data bytes, sending possible incomplete midi message 0x86
Serial In: Ch 1: Pitch bend 126
Serial In: Ch 1: System Message #8

when i hit any of six piezo it shows same message for all piezo.
please solve .............

capicoso

No need to start a new thread... Keep posting on the other one

el_supremo

There should be a special place in hell reserved for people who post yellow text.

Pete

el_supremo

I retract that comment. I realized after I had posted it last night, that it may not be obvious just how illegible yellow is. If you preview your post, the yellow shows up very clearly because the background colour used in a preview is not the same as that used in the final message.
You can edit your post (use the Modify option) and, if you must use a different colour at all (but why bother?), change the tag from color=yellow to something legible such as color=red.

But, please don't use yellow.

Pete

Go Up