Go Down

Topic: Error message when compiling (Read 1 time) previous topic - next topic

Festblatte

Hello,

i have the Arduino board for a while but evrytime I try to
compile a sketch this error message is shown:
Couldn't determine program size: C:\Dokumente und Einstellungen\Festblatte\Desktop\arduino-0013\hardware/tools/avr/bin/avr-size: 'C:\DOKUME~1\FESTBL~1\LOKALE~1\Temp\build52050.tmp\Blink.hex': No such file

It also occur when I try to compile the example sketches

Can someone help me?

Thanks and Goodbye

GordonEndersby


Ill be the first to ask:

Have you had this working in the past?
Which Arduino board.
Which version of the ide.
What operating system on your pc.

Have you selected the correct board.
Have you selected the right usb port ot serial port.

Have you gone through the getting started instructions.

Gordon

Festblatte

Hi,

Yes i have had this working in the past since I have the arduino.
I have the Arduino Diecimila.
I´d tried it with ide version 10 - 13.
My operation system is Windows XP Home edition SP3.

I have selected the correct board and the correct Usb port

I hope someone can help me.

Festblatte

mellis

[split] [link=http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1235832547][splithere][/link][splithere_end]

mellis

Festblatte: do you get any other messages when you try to compile a sketch?

Festblatte

mellis: No I only get the message form above

Festblatte

is nobody there who have an idea how to fix this problem?

Cybot

Try moving the files closer to C:\ drive and make sure app is running as admin, board is installed correctly and is right com port..
Cybot

Festblatte

I moved the files as close as possible to the C: and
the app is running as admin, but it doesn't help
anything.
I think its not a porblem with avr-size.exe
I think the problem is a bug in Arduino software.

Festblate

mem


Quote
Yes i have had this working in the past since I have the arduino.
I´d tried it with ide version 10 - 13.

Quote
I think the problem is a bug in Arduino software.

Why do you think that?

If it no longer works with earlier Arduino versions that used to work, something has probably changed in your environment that has stopped it working.

Festblatte

I have Problems with my JRE.
I only haver JRE 1.6 because i can not install newer versions
Can it have somethig to do with this?

Festblatte

mem

I run java build 1.6.0_11 on XP Pro SP3 without problem.

Perhaps look at the windows event view to see if you are getting any warnings or errors that could give a clue as to what is happening.

florinc

#12
Mar 09, 2009, 03:28 pm Last Edit: Mar 09, 2009, 03:28 pm by florinc Reason: 1
Try doing these steps:
1. delete C:\DOKUME~1\FESTBL~1\LOKALE~1\Temp\build52050.tmp\Blink.hex (in windows explorer);
2. if you are not allowed, the file may be missing (but a reference to it still around) or just locked somehow; in this case, restart your computer and perform 1. again (it should work this time);
3. restart Arduino IDE, load the sketch from the example directory; compilation (and save) should work now.


Festblatte

The only problem is that Arduino always delete the build52050.tmp
directory when its closed because this directory is in the directory
for the temporary files.

Festblatte

Andrew

If you set build.verbose=true in the Arduino IDE preferences.txt file then it should show you more what's going on and give a clue how to fix it.

Andrew

Go Up