Pages: 1 [2] 3   Go Down
Author Topic: capteur de contrainte  (Read 1887 times)
0 Members and 1 Guest are viewing this topic.
Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci
je remets 2€ dans la machine pour compléter :

1- je dois comprendre que ce que je lis en A0 de l'arduino ce n'est pas la tension de sortie mais le "nombre de pas" de lecture ?

2- tu me conseilles d'utiliser le Vref 5v de l'INA (soit le pin 15) plutôt que la sortie Vout (pin 10 et 11) ? pourquoi ?

merci
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5180
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci
je remets 2€ dans la machine pour compléter :

1- je dois comprendre que ce que je lis en A0 de l'arduino ce n'est pas la tension de sortie mais le "nombre de pas" de lecture ?

2- tu me conseilles d'utiliser le Vref 5v de l'INA (soit le pin 15) plutôt que la sortie Vout (pin 10 et 11) ? pourquoi ?

merci
-1 oui
-2 non
je crois que tu n'a pas bien compris le fonctionnement de l'INA

Avec l'INA tu dispose (à la condition qu'il soit au moins alimenté à 10V +1.25 , le plus simple et pratique en 12V)
de tensions de references disponibles en  2.5  ,5 et 10 V

- tu utilise la sortie 10V pour exciter ta jauge et la sortie 5V comme reference de tension pour l'arduino
pin15 de l'INA vers AREF de l'arduino , en oubliant pas de declarer dans ton programme
Code:
analogReference(EXTERNAL);
il ne te reste ensuite qu'à definir le gain avec RG pour obtenir 5V (1023 sur A0) avec 100 Kg de charge (ou 102.3 pour simplifier la suite)
« Last Edit: July 27, 2014, 01:56:30 pm by Artouste » Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

merci
je n'avais pas noté qu'il me fallait alimenter l'Ina en 12v.  je vais chercher une alim 12v
quels sont les conséquences de  l'alimentation en  5v?


par  contre je ne comprends pas le point  2 :
pourquoi définir une référence externe qui va définir la tension de référence à 5v alors que par défaut la tension  sur  A0 est de  5v?

a
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5180
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

merci
je n'avais pas noté qu'il me fallait alimenter l'Ina en 12v.  je vais chercher une alim 12v
quels sont les conséquences de  l'alimentation en  5v?


par  contre je ne comprends pas le point  2 :
pourquoi définir une référence externe qui va définir la tension de référence à 5v alors que par défaut la tension  sur  A0 est de  5v?

a
bonjour
en standard la tension de reference est = à la tension d'alimentation de l'arduino
et cette tension d'alimentation n'est PAS une reference de tension fiable, elle fluctue/varie fortement avec la conso instantanée, la source d'alim et d'autres parametres.
l'ina125 lui te fourni une vraie reference de tension, simple à utiliser , il suffit simplement de le declarer dans le programme
Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci

n'ayant pas d'alim 12 v sous la main j'ai utilisé une 15v. L'INA acceptant jusqu'à 36 ce doit être OK

si je débranche l'Arduino et le V+ u capteur j'ai effectivement 15v sur le V+ de l'INA et respectivement 10, 5 et 2.5v sur les pins 16,15 et 14
tout va bien
si je branche le V+ du capteur sur le 10v de l'INA, la tension alors mesurée sur ce pin (16) n'est plus que de 5.6v et, la Vref 5v (pin 15) de 2.6

est ce normal ? par ce que du coups, l'Arduino ne reçoit pas du 5v sur l'AREF

au passage, mon capteur ne réagit plus : il reste à 0 et passe à 1023 si je retire l'alim.

merci
Logged

france
Offline Offline
God Member
*****
Karma: 15
Posts: 879
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

j'ai l'impression que tu mélanges les broches  du INA125P
pin1 = V+
pin12-15 = Vref
pin4 = 10V pour le pont
tu as branché quoi sur quoi ?
Logged

Christian

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

salut
pin1 : V+ = 15v de mon alim
pin2 : sleep = 15v
p3 = gnd
p4<->p16 ( = vref 10v)
p5 = gnd
p6 signal+
p7 = signal-
p8 R300 P9  = Rg
p10 <-> p11 = vout -> A0 arduino
p12 = gnd
p13, p14 : rien
p15 = vref5v -> aref arduino
p16 <-> p4 = vref 10v

Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5180
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

salut
pin1 : V+ = 15v de mon alim
pin2 : sleep = 15v
p3 = gnd
p4<->p16 ( = vref 10v)
p5 = gnd
p6 signal+
p7 = signal-
p8 R300 P9  = Rg
p10 <-> p11 = vout -> A0 arduino
p12 = gnd
p13, p14 : rien
p15 = vref5v -> aref arduino
p16 <-> p4 = vref 10v



pour test
reste/reviens  avec AREF = V alim arduino (mode standard)
attention à une chose avec RG , il ne faut pas que vout de l'INA depasse 5.5V (Absolut max rating) sur A0 ,  mesure déjà le vout de l'INA avec un multi pour regler vout max à 5V en agissant sur RG
Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

ok
je teste demain matin

par sécurité, j'ai mis un R10K  en sortie Vout
Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

après essais, il s'avère que si j'alimente l'ina125p avec autre chose que du 5v, le capteur est comme "non alimenté". C'est à dire que les données remontées sur l'A0 sont identiques aux données remontées lorsque le capteur est débranché

lorsque j'alimente l'INA en 15v, le pin 4 donne bien du 5v mais le capteur ne réagit pas
par contre, si j'alimente le capteur direct en 5v, il réagit et me donne des valeurs en fonction de lapression
le pb c'est ue ces valeurs ne sont pas linéaires

sauf à changer de capteur je n'ai pas beaucoup d'idées ...
« Last Edit: July 29, 2014, 06:56:30 am by Felix83 » Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5180
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

après essais, il s'avère que si j'alimente l'inap avec autre chose que du 5v, le capteur est comme "non alimenté". C'est à dire que les données remontées sur l'A0 sont identiques aux données remontées lorsque le capteur est débranché

lorsque j'alimente l'INA en 15v, le pin 4 donne bien du 5v mais le capteur ne réagit pas
par contre, si j'alimente le capteur direct en 5v, il réagit et me donne des valeurs en fonction de lapression
le pb c'est ue ces valeurs ne sont pas linéaires

sauf à changer de capteur je n'ai pas beaucoup d'idées ...
bonjour
Dans la mesure où tu n'a pas de vrai datasheet du capteur , ce n'est pas simple de reflechir correctement  smiley-mr-green
peut etre un "probleme" du à l'impedance du capteur.

que releve tu à l'ohmetre comme resistance entre le branche du pont de jauge (pont seul et deconnecté de tout) ?
Logged

France
Offline Offline
Faraday Member
**
Karma: 39
Posts: 3626
There is an Arduino for that
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

si je branche le V+ du capteur sur le 10v de l'INA, la tension alors mesurée sur ce pin (16) n'est plus que de 5.6v et, la Vref 5v (pin 15) de 2.6

est ce normal ? par ce que du coups, l'Arduino ne reçoit pas du 5v sur l'AREF
Ton capteur présente une impédance assez faible. Peut être charge-t-il trop la référence.
Dans la doc de l'INA125 il est suggéré de mettre un transistor pour augmenter la sortance de Vref.
Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


que releve tu à l'ohmetre comme resistance entre le branche du pont de jauge (pont seul et deconnecté de tout) ?

,
je mesure 348 sur le v+ et 288 sur les S+ et S-
Logged

Offline Offline
Faraday Member
**
Karma: 34
Posts: 5180
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


que releve tu à l'ohmetre comme resistance entre le branche du pont de jauge (pont seul et deconnecté de tout) ?

,
je mesure 348 sur le v+ et 288 sur les S+ et S-
ok
~ 350 ohms , ça doit tirer un peu trop sur l'INA pour excitation
dans ta configuration où tu obtient des resultats ,  tu obtiens  quoi comme courbe au multimetre pour 0/100 Kg avec des paliers de 10 Kg avec excitation en 5V en calant RG pour 100 Kg=5V ?
Logged

Provence - France
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

j'attends un nouveau capteur et je refais des essais

merci
Logged

Pages: 1 [2] 3   Go Up
Jump to: