Go Down

Topic: Getting started with LilyPad Xbee (Read 702 times) previous topic - next topic

inesAD

Hello! I'm trying to start a project with LilyPad Xbee but I can´t upload the code to my board and I don´t know why.
I´m trying to upload a simple example code, so the problem is not on the code.
I think maybe I need to reset the board as in the LilyPad board, but LilyPad Xbee doesn´t have a button to do that. So I have connected the "reset pin" to de "+ pin" to try to reset but the code still didn't upload.

Sorry if this is a stupid question, but I can´t figure it out and I didn´t find any usefull information about how to work with LilyPad Xbee.

Hope you can help me. Thanks in advance.

darudude

There is no arduino in the lilypad xbee. are you trying to upload the code to the xbee?

inesAD

Ah! So the LilyPad Xbee is just a sewable shield for the Xbee? It's not a LilyPad Arduino that supports an Xbee?

darudude


inesAD

ok, thanks. I didn't know that.  :(

faludi

The LilyPad XBee isn't just a shield. Yes, it can be used with an Arduino but in many projects that won't be necessary. Since the XBee has six analog inputs and eight digital i/o pins for direct sensor transmission or as a receiver for lights and actuators, it can often be used independently.

Link by the way is http://lilypadxbee.katehartman.com

inesAD

Thanks for your answers. My project is now working. I'm using the LilyPad Xbee connected to one LilyPad Arduino, as it's used in the project 'Dream Squawk' http://semiotech.org/wp-prod/?p=166 so I don't need to change my code and it's all working.  :)

Go Up