Pages: [1]   Go Down
Author Topic: Sketch size 0 bytes?  (Read 1922 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've tried searching for this but haven't really found this exact issue:

I have a free duino decimilia.

I'm currently just testing the example sketchs that come with the IDE. I click upload and see the RX/TX leds blinking away so it looks like its transferring the sketch. But the IDE comes back and says "Binary sketch size: 0 bytes. (of a 14336 byte maximum)." And the sketch doesn't run on the board. Just sits there doing nothing. The LED on pin 13 just kind of stays lit rather than blinks (regardless of the sketch).

Any ideas?

thanks
Logged

Montreal
Offline Offline
Full Member
***
Karma: 0
Posts: 185
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Could you post the code of the example?
I will try it on my Duemilanove
Logged

Patgadget
Montreal

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the reply.

Standard blink example:

/*
 * Blink
 *
 * The basic Arduino example.  Turns on an LED on for one second,
 * then off for one second, and so on...  We use pin 13 because,
 * depending on your Arduino board, it has either a built-in LED
 * or a built-in resistor so that you need only an LED.
 *
 * http://www.arduino.cc/en/Tutorial/Blink
 */

int ledPin = 13;                // LED connected to digital pin 13

void setup()                    // run once, when the sketch starts
{
  pinMode(ledPin, OUTPUT);      // sets the digital pin as output
}

void loop()                     // run over and over again
{
  digitalWrite(ledPin, HIGH);   // sets the LED on
  delay(1000);                  // waits for a second
  digitalWrite(ledPin, LOW);    // sets the LED off
  delay(1000);                  // waits for a second
}
Logged

Montreal
Offline Offline
Full Member
***
Karma: 0
Posts: 185
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

this is what i get when i verify it
Code:
Binary sketch size: 1124 bytes (of a 14336 byte maximum)

Could it be that you need to include librairy (*.h) to make it work? in your environement?
Logged

Patgadget
Montreal

0
Offline Offline
God Member
*****
Karma: 0
Posts: 572
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you just installed the arduino IDE for the first time, or just recently upgraded it? Or modified the preferences.txt file?

You can see this error when there is no board selected in the Tools->Board menu.

Try choosing a board, then re-verifiying
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried selecting the board again, and the java console threw a whole bunch of warnings about various cpp files:

example:
Stepper.cpp:1: warning: -ffunction-sections may affect debugging on some targetsIn file included from Stepper.cpp:48:

The sketch still fails and shows 0 bytes.

However I thought more about trialex's response and dug up an older version of the ide (0011 alpha) that I had on my filesystem and tried the same sketch there. It worked. So something with this newer version - 0013 is causing me problems. Maybe I'll try building from source.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I am having the same issue with 0013 (but not 0012) on Debian Etch, so I tried 0013 on Debian Lenny and it works correctly. I suspect the old versions of avr-libc or gcc-avr in etch, but I haven't done enough testing to confirm it.  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 6
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yeah thats what I'm thinking too. I'm also running Debian etch. I'll look for updated versions when I get some time/patience.
Logged

NCL
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the same problem on an eeepc with xandros variant (which I believe is based on a fork of debian etch).
cheers
Brian
Logged

Pages: [1]   Go Up
Jump to: