Go Down

Topic: Help Uploading to Duemilanove on Macbook (Read 469 times) previous topic - next topic

uberninja

Hello all,

I recently bought my first arduino, specifically the duemilanove. I have tried getting the processor to play nice with my Macbook running 10.5.6 using the Make book and the guide on the arduino website, but no luck so far. The green power light is on. I have installed the latest FTDI drivers (2.2.10), and have selected the dev.tty.usbserial-A6008dpO serial port in the program, as well as trying others when that didn't work. Everything I choose comes up with "Problem uploading to board." At the bottom, this is displayed:
avrdude: stk500_getsync(): not in sync: resp=0x20
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0xcc

I am really excited about getting to learn all about the arduino, and any help would be greatly appreciated!

Anachrocomputer

Did you select the right type of Arduino board and CPU from the menu in the IDE?

chmijo

I am having the same problem did you fix it?

bohne

Like Anachrocomputer said: check if you have selected the right board and mcu. If you have an atmega328 on your Arduino (the microcontroller) then you must select a board that uses the 328 (e.g. "Arduino w/ ATmega328")
http://www.dorkbot.de
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1236434254
http://www.luminet.cc

James C4S

After determining if you've selected the right board, another thing to try is a different serial port.  If you have a "dev.cu.usbserial-A6008dpO" available, use that instead of the tty port.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

uberninja

Great, it worked! Thanks so much for the help. I had to switch over to the Duemilanove with the 328 and switched to the /cu serial and it worked like a champ. I appreciate the support!

Go Up