Go Down

Topic: Interesting FTDI issue (Read 1 time) previous topic - next topic


I have four Arduino Duemilanoves I'm using for a project.   Three of them (Boards 1-3) have an interesting problem that is driving me crazy.

Board #0 is a good board.  When connected to the USB of a Mac OSX or Windows 7 box it works perfectly.  I can program it, I can see in the serial monitor that it is working.  Perfect.

Boards #1, #2, and #3 all have the same problem.  When connected to the USB of the Mac OSX box I can program them, I can see the output of the program on a serial monitor.  They work perfectly.   However, when connected to the USB of a Windows box (USB 2.0 ports), they don't work.  The windows laptop sees the FTDI chip, installs the drivers, equips the Serial port (COM 137, 138, and 139).   But programming fails with the following error.

         Using Port                    : \\.\COM137
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [00]
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

So, I decided to see what might be going on by checking out boards 1, 2 and 3 with a loop back test on the windows laptop.
Total failure.  No echo back of data sent from from the serial monitor.   Now, I was totally confused, why would the boards not echo the data back.  They worked on the Mac.   So, I tried the loopback test on the Mac.  It worked the data was echoed back. 

So now I am totally lost.  Why is this happening?   When connected to the Mac, the boards work perfectly.   When connected to a Windows 7 laptop they won't even echo data back when in loop back test mode.  Oh, board #0 works perfectly when put into loop back test mode on both the Mac and the Windows 7 laptop.   

I'm convinced boards 1, 2, and 3 have some problem I just can't figure out what it is.



Didn't help.  No change.   This is so odd.


I have now tested these Duemilanoves on multiple Windows machines and on multiple Macs.  Board 0 works on all Windows and Macs.   Boards 1-3 only work on Macs.  On the Windows machines they don't work.  I am stumped.

This makes no sense whatsoever.


Oh, thanks Zapro for the suggestion.


There was bad batch of FTDI chips out for a while counterfeits that didn't work. Maybe you have some of those.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


Board 0 works on all Windows and Macs.   Boards 1-3 only work on Macs.  On the Windows machines they don't work.  I am stumped.

I'd say fake FTDI-chips!


// Per.


Direct hit guys.  Those chips are fake.  The driver is returned nothing but binary zeros no matter is what is actually returned by the processor.  Argh! 

I proved it by swapping a known good processor with the processor on board 1.   Still didn't work.  That functionally left only the FTDI chip as the culprit.   Three boards, three bad FTDI chips?   Then I traced the pinouts on the FTDI chip to their destinations.  All good and all electrically good.  That left the FTDI itself.   

Then a quick check on the data being returned by the driver.  Sure enough, it's binary zeros.

Thanks for the documentation on the bad chips.   Time to go throw a fit at the place I bought them from.

Go Up