Pages: [1]   Go Down
Author Topic: Have I blown a board, or just a bootloader?  (Read 371 times)
0 Members and 1 Guest are viewing this topic.
UK, Southwest
Offline Offline
Full Member
***
Karma: 5
Posts: 138
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is 012 on linux, Duamilanove.  On the last sketch change, the sketch does not load, the serial port (a USB one) is no longer recognised by the machine (on any USB port); both TX and RX lights are hard on.  Doing a reset makes no difference.

However the sketch which blinks an output seems to still be working.
 

Is there any way of deciding whether the board is fried, or whether the bootloader has just failed? I suspect the USB to serial chip.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 56
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Could be the atmega chip.  They are cheap to replace.  I think that is the best-case-scenario anyways.
Logged

UK, Southwest
Offline Offline
Full Member
***
Karma: 5
Posts: 138
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I would like to buy a few chips as replacement, can I get them with the bootloader already burnt (UK).

I don't know what the problem was - its now fixed.  Following morning, after a laptop reboot, all is working!!!  I did try every USB port on the laptop last night, and the device was not being recognised on any one of them.  

I did try the arduino on an external power supply this morning, before trying the USB again.  I wonder if I managed to overload the USB source?
Logged

Oxford (England)
Offline Offline
Jr. Member
**
Karma: 0
Posts: 58
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I would like to buy a few chips as replacement, can I get them with the bootloader already burnt (UK).
You can get 3 x 168s pre-programmed with an Arduino bootloader for £9.99 on eBay. Just search for Arduino.
[assuming that 168's are what's required of course!]
Logged

UK, Southwest
Offline Offline
Full Member
***
Karma: 5
Posts: 138
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I never thought of ebay.   I've ordered some spares now.  Thank you.

I now know what the problem is:  the arduino is driving 4 RS422 line transceivers, and also 4 LEDs to show the state of the input lines, and another indicator LED.  I think the USB power just got marginal. The problem happened again, and this time I plugged an external 5V PSU in.  The laptop saw the USB port as soon as I did that.
Logged

Pages: [1]   Go Up
Jump to: