Pages: [1]   Go Down
Author Topic: Unable to read Serial off of USB  (Read 170 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have a windows 7 64 bit computer communicating with an Ardunio Uno with drivers installed. When I plug in my USB, the processing no longer sees that the Uno is connected even though it show up in device manager. It gives the error "Serial Port 'COM4' not found" when I try to open the serial monitor or if I try to upload a program. This was happening before, and unplugging and re-plugging the cable would fix it. Now it just does not respond at all. It draws power, but nothing else. I tried swapping out cables, to no effect.

The arduino programming application has the Serial Port option in the Tools Menu grayed out.

I tried to write a python program to communicate with the ardunio, but I get the error  "SerialException: could not open port 'COM4': WindowsError(2, 'The system cannot find the file specified.')" This is the same program that worked a couple times, before the board stopped communicating entirely.

So both programs say that they can't talk to it, but the device manager has it showing up, and lists the drivers I am using.

Any suggestions?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Update: So I left my USB plugged in for awhile and left my computer, when I came back everything was working again. I'll update if the problem shows up again.
Logged

Rotherham England
Offline Offline
Full Member
***
Karma: 2
Posts: 179
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I sometimes get this, often after I have switched uno's. I find if I go to  tools/port and left click on the com port showing it fixes the problem as if the computer isn't sure which port it should be looking at.
Logged

Pages: [1]   Go Up
Jump to: