Go Down

Topic: This isn't working at all... (Read 937 times) previous topic - next topic

AeroNotix

Okay, so I got my Arduino though today and set it all up, being the firs time I've usd on I loaded up the "Blink" sketch, that worked great.

Started messing around with that code, adding in and taking away, adding extra LED's and stuff, I was getting the hang of the small amount of code I was using.

Anyway, now I can't upload at all. It has disappeared from the Port list completely where before it was something like USB to Serial coverter (COM3) but now it doesn't have anything there about it.

When I power the board up over USB, there is no sound to indicate that Vista has recognized that the board has been connected and I when I try uploading (using the different COM ports) then I get this message "avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51"

Also, when I power it up both the Rx and Tx lights are amber, and when I hit reset, the Pin 13 LED flashes once and never comes on again....

Please help me out I was having so much fun before this happened lol.

AeroNotix

#1
Apr 19, 2009, 04:09 am Last Edit: Apr 19, 2009, 04:10 am by AeroNotix Reason: 1
All these views and no reply? I hope it's because it's a very simple thing that I am doing wrong.

James C4S

Is the Atmel or the serial-to-usb chip (near the usb port) getting warm?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

estranged

Did your last sketch uploaded use digital pins 0 or 1?

AeroNotix

No, I've left the chip plugged in to see whether or not it would get warm, but no.

The last sketch I used included pins, 11, 12 and 7, also it used both grounds.

And I know you're going to think I'm a noob for doing it but I included Serial.begin at the start of the sketch to see what it would do, it compiled fine and all....soo....?

It seems like it's either A) Got a fried FTDI chip or B) Locked into something to do with the serial communication?

AeroNotix

Okay so I bought another board and this has the same problem. I honestly am starting to think I emit a magnetic field or something because things always break on me.

Please somebody help, if anyone gives me the answer then they will recieve an Arduino Pro.

Anachrocomputer

Can you tell us what machine and OS you're using?

AeroNotix

Sure, I'm running Windows Vista Service Pack 2, it's a 1.8Ghz with 2GB of RAM. It's a cheapo Acer PC that I've upgraded slightly. Also, I've tried it on a Acer laptop with roughly the same specs as the desktop.

I have Ubuntu on a partition on the desktop I might try and see if lsusb or dmesg gives me any information regarding when I plug the board in.

Grumpy_Mike

Quote
It has disappeared from the Port list completely where before it was something like USB to Serial coverter (COM3) but now it doesn't have anything there about it.


That is your problem. If that bit doesn't work then there is no point fussing about anything else.

Try un-installing the FTDI drivers and installing them again.

AeroNotix

#9
Apr 23, 2009, 03:49 pm Last Edit: Apr 23, 2009, 03:52 pm by AeroNotix Reason: 1
I've already tried uninstalling and re-installing the drivers.

I was using it on the laptop and it started with that error, so I switched to the desktop and the error persisted, which led me to buy another arduino.

In all honesty I'm actually quite glad that the problem is still present after buying another because now I have two arduinos that still may work!

Ray Andrews

Have you tried a different usb cable ?

AeroNotix

I thought about that but I've only just bought it (It came with the first Arduino) so I don't think it would be that to be honest, but I will try.

Go Up