Go Down

Topic: Problem uploading to Mini Pro via CP2103 (Read 634 times) previous topic - next topic

David Ritchie

Hi,

I have the following (all from coolcomponents):-
- Arduino Mini Pro 3.3V
- CP2103 USB to Serial Board

I'm running Leopard on a MacBook and have downloaded the CP2103 drivers and the Arduino environment. I'm trying to upload the simple blink program but it does not work. In verbose mode I see this:-

---------------------------
Binary sketch size: 976 bytes (of a 14336 byte maximum)
hardware/tools/avr/bin/avrdude -Chardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm168 -cstk500v1 -P/dev/tty.SLAB_USBtoUART -b19200 -D -Uflash:w:/Users/mandarin/Desktop/Blink/applet/Blink.hex:i


avrdude: Version 5.4-arduino, compiled on Oct  9 2007 at 11:20:31
...
        Using Port            : /dev/tty.SLAB_USBtoUART
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 19200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: Send: Q [51]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

----------------------------

I've got the VCC and GND pins of the Mini hooked up to the 3.3V and GND pins of the CP2103 board, and this causes the Mini to power up, since its little LED comes on. The LED near pins 10 and 11 (which is what the program is trying to blink) then starts to flash a few times, getting faster, until it stays on for a little while. Then it goes off and starts the blinking sequence again. When I hit the reset switch this happens too, but it just endlessly loops through that sequence anyway. I assume it's indicating that it's trying to transfer a program.

I have also hooked up the TX0 of the CP2103 to the RXI of the Mini and the RXI of CP2103 to TX0 of Mini. I then select the USB serial port on the Mac and the Mini Pro board from the tools menu and try and upload. Each time I just get the above - it seems the computer is getting no response from the Mini at all. I've tried switching the RXI->TX0 connections. I've tried selecting 'Lilypad' as the board (as I read somewhere) but I always get the same thing.

Am I missing something obvious here?


Many thanks,

-- David

mellis

The Mini Pro needs to be reset just before upload.  The bootloader is active for 1-2 seconds on reset.  Normally, this is done by taking the DTR pin low, which is connected to reset through a 100 nF capacitor on the Mini Pro.  But if you haven't hooked up DTR, you'll need to press the reset button just before hitting upload.

Go Up