Pages: [1] 2 3 4   Go Down
Author Topic: ArduinoBT on Mac OS X Leopard  (Read 4378 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Since our university chair switched all of its machines to Leopard noone seems to be able to upload programs to the ArduinoBT anymore. Uploading to usb-connected board still works and uploading from the few machines that still have Tiger works as well, it's just this one combination for which we can't find a solution. Is this a known issue and if yes is there anything to solve it?
If you need any more infos, feel free to ask
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm, what happens when you try to upload?  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Depends smiley
Arduino-0007 and 0008 usually just freeze and never come back to life
Arduino-0009 throws one of this two errors, depending on the reset-timing:
Quote
avrdude: ser_open(): can't open device "/dev/tty.ARDUINOBT_609-Bluetooth-1": Resource busy
Quote
Error inside Serial.<init>()
gnu.io.PortInUseException: Unknown Application
      at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
      at processing.app.Serial.<init>(Serial.java:127)
      at processing.app.Serial.<init>(Serial.java:72)
      at processing.app.Uploader.flushSerialBuffer(Uploader.java:67)
      at processing.app.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:69)
      at processing.app.Sketch.upload(Sketch.java:1699)
      at processing.app.Sketch.exportApplet(Sketch.java:1761)
      at processing.app.Editor$42.run(Editor.java:1955)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
java.lang.NullPointerException
      at processing.app.Serial.setDTR(Serial.java:480)
      at processing.app.Uploader.flushSerialBuffer(Uploader.java:76)
      at processing.app.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:69)
      at processing.app.Sketch.upload(Sketch.java:1699)
      at processing.app.Sketch.exportApplet(Sketch.java:1761)
      at processing.app.Editor$42.run(Editor.java:1955)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

And arduino-0010 gives me the first one as well as this one:
Quote
processing.app.SerialException: Serial port '/dev/tty.ARDUINOBT_609-Bluetooth-1' already in use.  Try quiting any programs that may be using it.
      at processing.app.Serial.<init>(Serial.java:140)
      at processing.app.Serial.<init>(Serial.java:72)
      at processing.app.Uploader.flushSerialBuffer(Uploader.java:66)
      at processing.app.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:55)
      at processing.app.Sketch.upload(Sketch.java:1632)
      at processing.app.Sketch.exportApplet(Sketch.java:1701)
      at processing.app.Editor$41.run(Editor.java:2004)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Weird.  I'll have to try it with my Leopard machine here and see if I can figure anything out.  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 22
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've got the same problem I think - I haven't been able to do anything at all with my ArduinoBT. I'm using MacOS Leopard on an Intel iMac with Arduino10.

The ArduinoBT will pair with the iMac, but it shows up as not connected - nothing I do seems to result in it connecting.

I'm usually getting the "ser_open(): can't open device...... Resource busy" error as Radioprotector's post, but sometimes it just hangs completely, and won't even force quit, so I have to physically power the iMac down.

I've spent a day on it now and got nowhere, really disappointing after using the excellent Diecimila especially as it costs so much. I'm on the point of giving up and trying to return the ArduinoBT.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having identical problems on Leopard.. When I try to upload a sketch Arduino 0010 either goes into an unrecoverable freeze or gives me a "resource busy".

Btw, If I put a led on pin 13 it blinks with an uneven but rather high frequency. When I press the reset button the blinking stops for about a half second, resumes for about a second, stops again for about 10 seconds and then resumes to blink indefinitely...  

Has anyone found a solution to this yet?
« Last Edit: February 07, 2008, 04:43:27 am by erik.sjodin » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I dug around for a while earlier in the week and tried skipping the Arduino software and just using avrdude. I'm not very experienced with Arduino but it seems like it could work. I was copying the blink hex file:

avrdude -n -v -F -p atmega168 -P /dev/tty.feestaArduino-Bluetooth -c stk500 -b 115200 -U flash:w:Documents/Arduino/Blink/applet/Blink.hex

It basically gave me the same, failed results as using Arduino 0010. I tried searching(googling) for problems with using avrdude on Leopard to no avail. I'm stepping beyond my experience but wondered if the stk500 bootloader is a problem with bluetooth in leopard. I don't feel comfortable fiddling with that on my ArduinoBT. too pricey to break.

support for the bluetooth board is appreciated!
« Last Edit: February 07, 2008, 04:59:11 am by feesta » Logged

0
Offline Offline
God Member
*****
Karma: 0
Posts: 731
skcor oniudrA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same problem too, Arduino 10, except OSX10.3.9 and an Arduino connected to a Firefly.

Serial connect works fine in carbon and zTerm, but Arduino throws an exception (no other applications running except A10)

Code:
processing.app.SerialException: Serial port '/dev/cu.Bluetooth-Modem' already in use.  Try quiting any programs that may be using it.
      at processing.app.Serial.<init>(Serial.java:140)
      at processing.app.Serial.<init>(Serial.java:63)
      at processing.app.Editor.handleSerial(Editor.java:1485)
      at processing.app.EditorButtons.mousePressed(EditorButtons.java:373)
      at java.awt.Component.processMouseEvent(Component.java:5163)
      at java.awt.Component.processEvent(Component.java:4963)
      at java.awt.Container.processEvent(Container.java:1613)
      at java.awt.Component.dispatchEventImpl(Component.java:3681)
      at java.awt.Container.dispatchEventImpl(Container.java:1671)
      at java.awt.Component.dispatchEvent(Component.java:3543)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3527)
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3239)
      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3172)
      at java.awt.Container.dispatchEventImpl(Container.java:1657)
      at java.awt.Window.dispatchEventImpl(Window.java:1606)
      at java.awt.Component.dispatchEvent(Component.java:3543)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:480)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Logged

New York, NY, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 40
Howdy. I don't check PMs often, so email me!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I got Arduino running under Leopard thanks to a post on the Processing boards.  Since Arduino relies on the Processing IDE, and that relies on the rxtx serial library, there are some permissions that need to be set.  There's a script in 0010 that does this automatically, but it relies on tools that Apple removed in Leopard.  Meanwhile, here's a fix copied from http://tinyurl.com/yojcf4:

 1. Under Finder click on the "Go" Menu
2. Select "Go to Folder..."
3. Type "/var/"
4. Finder will open var folder.
5. Right click on folder named "lock" and select "Get info"
6. Open drop arrow titled "Sharing & Permissions"
7. I set all privileges to: "Read & Write"
8. Close Info
9. Go to the Var folder on the finder and open the "spool" folder
10. Right click on folder named "uucp" and select "Get info"
11. Open drop arrow titled "Sharing & Permissions"
12. I set all privileges to: "Read & Write"
13. Close Info
14. DONE

Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm.   I'm surprised that fixed it, because the RXTX library that comes with Arduino should have locking disabled.  But, hey, if it works, it works.  

I also found that I had better success uploading when I commented out the lines in the IDE that attempt to flush the serial buffer (using RXTX) before uploading the sketch (with avrdude).  I'll try to incorporate this into Arduino 0011.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

Quote
5. Right click on folder named "lock" and select "Get info"

There is no /var/lock/ folder on my Leopard System (10.5.2., G5 PPC)  :-?

Same problems here, I cannot upload anything to my Arduino BT; the port seems to be "busy" all the time. Is there any Arduino-Processing 11 beta available yet?

Best,
Michael
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you don't have /var/lock/

then:

in a terminal window do the following where % is your prompt

%sudo mkdir /var/lock/
password:

(when it asks for your password just type it in. This assumes you have administrative access.)

then do tigoe's steps.
« Last Edit: March 01, 2008, 04:08:23 pm by dgclogic » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for your reply, dgclogic.

Unfortunately, even after setting read&write permissions to var/lock and /var/uucp, and restarting both my pc and the ArduinoBT multiple times, I still get the same error when I want to upload the test program (Blink) to the Arduino BT:

When I try to upload, there's an immediate short BT-connection, and a spike in the power consumption of the board (from 0.04 to 0.10 A). About 1 second later, the connection is down again, and about 10 seconds without any BT activity, I get this error message in the Arduino-010 console:
"avrdude: ser_open(): can't open device "/dev/tty.ARDUINOBT-BluetoothSeri-1": Resource busy"



I also tried to recompile the svn source to remove the serial flushing, but there's an error as well (in the unchanged source) :
"unexpected EOF while looking for matching ''" in /bin/sh; resulting in the build error:
"Command /Developer/Private/jam failed with exit code 1"

Sorry I'm not an experienced Java programmer, although I have some experiences in Cocoa / Obj-C programming. But I'm having difficulties here. Is it maybe possible to check out the last stable 010 version somewhere?

I'd really like to be able to upload my programs to the Arduino BT from the mac. Has anyone of you succeeded in the meanwhile? Or is this a general Leopard issue?

Thanks for any help,

Best,
Michael
Logged

Brasília, Brazil
Offline Offline
Jr. Member
**
Karma: 0
Posts: 54
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had similar error in windows, can anyone help me solving it?

The problem is the following:

(Arduino 0010 and 0009)
 
Binary sketch size: 1108 bytes (of a 14336 byte maximum)
 
 
Error inside Serial.<init>()
 
gnu.io.PortInUseException: Unknown Application
 
     at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
 
     at processing.app.Serial.<init>(Serial.java:127)
 
     at processing.app.Serial.<init>(Serial.java:72)
 
     at processing.app.Uploader.flushSerialBuffer(Uploader.java:67)
 
     at processing.app.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:69)
 
     at processing.app.Sketch.upload(Sketch.java:1699)
 
     at processing.app.Sketch.exportApplet(Sketch.java:1761)
 
     at processing.app.Editor$42.run(Editor.java:1955)
 
     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
 
     at java.awt.EventQueue.dispatchEvent(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 
     at java.awt.EventDispatchThread.run(Unknown Source)
 
java.lang.NullPointerException
 
     at processing.app.Serial.setDTR(Serial.java:480)
 
     at processing.app.Uploader.flushSerialBuffer(Uploader.java:76)
 
     at processing.app.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:69)
 
     at processing.app.Sketch.upload(Sketch.java:1699)
 
     at processing.app.Sketch.exportApplet(Sketch.java:1761)
 
     at processing.app.Editor$42.run(Editor.java:1955)
 
     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
 
     at java.awt.EventQueue.dispatchEvent(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
 
     at java.awt.EventDispatchThread.run(Unknown Source)
 
It seens that the port is in use... (?????)
 
Windows XP SP2
BT658 - V06
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 23
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

sorry Brenin, struggeling myself;
it may make sense for you to open up a new topic, because this one is about Mac OS X Leopard and it's most likely that the cause of your troubles is something different: your log states "port in use", while I get "Resource Busy".
The "Port in use" info normally indicates that there's really something using the port, so you should make absolutely sure to exit any program that might possibly use your BT connection, incl. autostart programs.


I'm honestly sorry if I seem impatient, :smiley
but I just tested everything again, now on my PowerBook (also 10.5.2, PPC) and I get exactly the same results as on the G5! "Resource busy"... so it seems I won't sleep well again, until I know if -
  -> anyone has succeeded in uploading programs to Arduino BT with Leopard on a PPC machine?
  -> it is possible to download the Arduino Processing 010 source (stable) somewhere, so that i can compile it disabling the serial flush?
  -> there is any reference how to possibly upload programs alternatively, eg. manual hex-upload with Xterm?

so thanks a lot in advance to anyone responding!
Cheers,
Michael
Logged

Pages: [1] 2 3 4   Go Up
Jump to: