Go Down

Topic: ArduinoBT on Mac OS X Leopard (Read 12745 times) previous topic - next topic


the board will not actually connect to my macbook's bluetooth at all. i have tried the things suggested on the forum, e.g resetting the bt module, checking the serial ports of the macbook's bt and the arduino bt's.

i was also wondering what the auto-flushing is on the arduino, cos i can't seem to find that or what it is?

thanks, hope that is detailed enough


kk: have you tried resetting the BT module from within your sketch?  There's an example here: http://www.arduino.cc/en/Main/ArduinoBTInitializationSketch.  

Thanks for the answer Mellis!

I uploaded the BT configuration reset sketch, the led happily blinked so it was executed for sure.
But still I get errors if I try to open the serial port without resetting the board. I'm on OSX 10.4.8.

I get this:
"Serial port already in use. Try quitting any programs that may be using it."
And this console message:
"processing.app.SerialException: Serial port '/dev/tty.ARDUINOBT-BluetoothSeri-1' already in use.  
Try quiting any programs that may be using it. ..."

No other program is using the port (at least visible programs)
I have disabled the file exchange services from osx BT preferences,
and still I can only connect with the same procedure:
reset the board and press serialmonitor just after resetting.
With this I can always connect, but it's not really useful for a wireless device...
I have 2 boards, both behave in the same way, both are BT-V06.

Have checked the background processes of OSX that involve bluetooth, and maybe keep the port busy,
because it seems that I can connect only during the "reset pause"
and that once the code starts running there's no way to connect without resetting.
Found only this "blued" that should manage the BT connection but don't know exactly how to go further...
If anyone can help I'd really appreciate, I'm totally clueless and wanna use this boards...  

Thanks for your attention,


I have read and tried the solutions and they are still not working.  I am terribly new at this and see that the thread stopped in May.  Did everyone get it to work or did they just give up?


Did everyone get it to work or did they just give up?

yes, it's working, though you must check two things:
1. check the secure connection with the serial port
2. try and if it's not working try again. The last time I had to try about 10 times. I guess it has something to do with the authorisation in OSX. And even then you have to find the right timing resetting the BT board and uploading the patch.

Just don't give up ;-)



May 20, 2009, 06:55 am Last Edit: May 20, 2009, 06:56 am by rem7 Reason: 1
I'm trying to connect my ArduinoBT and I'm having problems as well. I'm using Arduino 0015 on Leopard. I was able to pair it with my computer and when I click "Upload to IO board" I can see in my mac preferences the arduino connecting however in the IDE I get:

Code: [Select]

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding


May 20, 2009, 09:56 am Last Edit: May 20, 2009, 09:57 am by auco Reason: 1
restart the device while or immediately before the upload process starts (and check out the faq... imho not related to the problem discussed in this thread)



well, perhaps I should have mentioned that I am able to upload when I'm using Windows XP and Windows 7 just fine (restarting the board during the upload process).

This thread is about getting Mac OSX and Leopard to work, so I figured it would be relevant since I can't seem to get it to work in leopard.

Go Up