Go Down

Topic: Burning Blank Atmega328 With Duemilanove (Read 854 times) previous topic - next topic

SpikedCola

Aug 15, 2009, 05:21 am Last Edit: Aug 15, 2009, 05:23 am by SpikedCola Reason: 1
I picked up a blank atmega328 chip today to rig something up. I popped out my good chip and put in the blank, built an X3-to-ICSP cable as per here.

I then followed this guide, but the IDE hangs as soon as I select the burn bootloader option. The only way to unhang it is to use Task Manager to end the avrdude.exe task. When I do, I get the following in the console box at the bottom:
Quote
avrdude.exe: BitBang OK
avrdude.exe: pin assign miso 3 sck 5 mosi 6 reset 7
avrdude.exe: drain OK
ft245r:  bitclk 4800 -> ft baud 2400
ft245r:  bitclk 4800 -> ft baud 2400
avrdude.exe: BitBang OK
avrdude.exe: pin assign miso 3 sck 5 mosi 6 reset 7
avrdude.exe: drain OK


Ive waited up to ten minutes before ending the task, but it doesnt make a difference.

I tried using this method and it finishes successfully, but when I unhook the cable and use the IDE to try to upload a sketch (Blink), it compiles fine, but when it uploads, it tries for about 20 seconds, then it gives me this error:
Quote
Binary sketch size: 896 bytes (of a 14336 byte maximum)

avrdude.exe: stk500_getsync(): not in sync: resp=0x37
avrdude.exe: stk500_disable(): protocol error, expect=0x14, resp=0x51


What should I do?

lwhi

Not sure about this method - but last week I successfully used http://code.google.com/p/mega-isp/ to burn a bootloader onto an ATmega328p.

http://www.uchobby.com/index.php/2007/11/04/arduino-avr-in-system-programmer-isp/ describes it in more detail.

You don't need anything other than yr Arduino and a couple of bypass capacitors to get this working.

SpikedCola

So I set the IDE to burn the bootloader, and left it overnight, and Im not sure how long it took, but I FINALLY got a successful bootloader burn. I guess the 'this may take a minute' is a gross understatement.

Thanks to all those who read this thread! Problem solved.

RoyK

#3
Aug 16, 2009, 10:51 am Last Edit: Aug 16, 2009, 10:52 am by RoyK Reason: 1
I burned bootloaders to five 328s the other day using a USBTinuISP and it took several minutes for each -- didn't time it but it was more than one minute and less than ten. It is pretty slow but it does work.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy