Go Down

Topic: Etched a Purpose-Built Arduino - It Does Nothing! (Read 958 times) previous topic - next topic

SpikedCola

Oct 07, 2009, 11:28 pm Last Edit: Oct 08, 2009, 01:18 am by SpikedCola Reason: 1
Ive been working on a small board to control some lights and read from some sensors, and display the info on an LCD. I got the code figured out on my Duemilanove, so I decided to create a board so that I can use my Duemilanove for something else. Here is the schematic, board layout, and pictures of it etched:




^^ the trace on the right in the middle that looks like it is shorted to the ground plane was fixed















I had a hell of a time soldering it all together, as I made the pads around components too small, but eventually I got it all soldered up. However, when I power the board, I cant upload anything to it. Ive broken out VCC, GND, RST, TX and TX, which I connect to my Duemilanove, and remove the Duemilanove's chip, which has worked with other boards Ive made. However, it gives me this error:

avrdude.exe: stk500_getsync(): not in sync: resp=0x00
avrdude.exe: stk500_disable(): protocol error, expect=0x14, resp=0x51

I tried pulling the chip and putting it in the Duemilanove, and it programs just fine (thankfully testing with the etched board didnt/doesnt kill it!) so I uploaded the Blink sketch, and put it back in the etched PCB. Nodda. No blinking light or anything. It doesnt even blink when you first power it on. I have checked continuity on the crystal and all the power lines to the chip and they check out. Ive also checked for power on the chip and that checks out too.

What else can I check?
Thanks!

Grumpy_Mike

#1
Oct 07, 2009, 11:36 pm Last Edit: Oct 07, 2009, 11:39 pm by Grumpy_Mike Reason: 1
Quote
What else can I check?

Check that the reset is not being held low. Get a scope and check the crystal is going.

Have you a picture with the components on it?

Is the ground plane connected to 0V, it doesn't look like it is?

SpikedCola

Plugging in the scope now.

Im uploading more pictures, which include the components and the soldered side.

The ground plane is connected to ground. Look for thermals - thats where it connects to ground points.

condemned

Are different fuse settings needed for a ceramic resonator?

SpikedCola

Pictures uploaded.

AFAIK, no. Ive used the resonator with a similar board that was made using perf-board and wire, and I had no problems programming and running it like Im trying to now.

Go Up