Go Down

Topic: Bootloading problem (Read 479 times) previous topic - next topic

bobi-one

Hi, i bought  ATMEGA168-20PU  and  tried to put bootloader  with a Diecimila board and a parallel programer, but every time i try to "burn" i get:
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA168 is 1E 94 06
avrdude: AVR device not responding
***failed;  
avrdude: verification error, first mismatch at byte 0x0000
        0x00 != 0x07
avrdude: verification error; content mismatch

ive tried another atmega168 but still the same error msg.

im using windows 7 and 0017
please help  :-/

Johan Adler

Has the programmer worked for you before? What kind of a programmer is it? Can you use it from the Arduino IDE?

What exactly is the commandline you are using? I am not sure whether the ATmega 168 and 168p has different signatures, if they do you might try specifying the version that you have not yet tried.

bobi-one

the programmer works, once i did burn on atmega8 bootloader,  
the  letters "pu" means its DIP package i think

wayoda

Hi, just wondering

Quote

the programmer works, once i did burn on atmega8 bootloader,  


....but does it work on windows7, too?
Eberhard

bobi-one

tried  under ubuntu avrdude  but same result... none..  i think the ltp port has burned out

Johan Adler

"lpt" -- is it a parallell port programmer, then? Homebuilt?

PU in this case is the package, I believe, but there are also two versions of the 168, plain old 168 and new Picopower 168p. They may or may not have different signatures.

bobi-one

yes the programmer is the one from the arduino site with the  3 resistors, i dont think this p will make a diference , i ll buy a  usb to  lpt  and try it out, hope this time it works

Go Up