Go Down

Topic: Good Tutorial To Learn 7" LCD Screen With Shield For Arduino Mega or Due? (Read 698 times) previous topic - next topic

avr_fred

Perhaps I missed it but I don't see we're you've identified the processor you are using.
So, which is it? A Mega or a Due?

Also:

CTE70CPLD is not a model the library understands.


Incorrect. That is a valid model and is exactly what the OP should be using. If he has a Mega, the correct UTFT model would be:

UTFT myGLCD(CTE70CPLD,38,39,40,41);

If the type CTE70CPLD is not recognized, you have a older, out of date version of UTFT and you should download the current version from the UTFT website.

Also be sure to select the correct 800x480 demo from the AVR choices, not the ARM versions. Once you have the correct demo sketch open, change the display type from ITDB50 to CTE70CPLD and that should run without further drama. You do not need any SD cards to run the UTFT demo.

Finally, if you are using a Due, you have the wrong shield. You need this version: http://www.ebay.com/itm/TFT-SD-Shield-for-Arduino-DUE-TFT-LCD-Module-SD-Card-Adapter-2-8-3-2-inch-Mega-/121057447668?


HazardsMind

Quote
Incorrect. That is a valid model and is exactly what the OP should be using. If he has a Mega, the correct UTFT model would be:


Yea, I haven't updated the library in about 2 months(maybe longer), but the only thing that changes with the models is the screen resolution and mode. The 7" screens are usually 480x800 and 16bit, which should work with the models I told him to use. I can't update the library right now, the site is under maintenance.
My GitHub:
https://github.com/AndrewMascolo?tab=repositories

jdlev

I got it working.  Turns out the arduino doesn't provide enough power to the screen on it's own, so you have to use the DC power supply.  Hooked it up, and the red/white lines vanished, and it ran through the demo.

Go Up