Go Down

Topic: AVR Dude Error (Read 12340 times) previous topic - next topic

1


1

have a diecimila and got the same thing
just got 0016
loop feedback does not work
i am just doing Blink
i got with verbose mode on:

Binary sketch size: 896 bytes (of a 14336 byte maximum)


avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/


        Using Port            : \\.\COM4
        Using Programmer      : stk500v1
        Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.


:exclamation [glow]I Need Help![/glow]  :exclamation

madworm

loop feedback does not work

are the FTDI drivers installed properly ?
do you see an additional serial port when you plug it in ?
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

inthebitz

hey guys, i just saw this post come up about the mega... i don't really know what it might be, but the one i have at home works perfectly? i have a vista laptop that pretty much never worked (for some reason the driver crashes my computer every once in a while when it downloads, but that's with the diecimila and duemilanove too), so i always do programming on my xp desktop.

sadly i'm still at work :-( but i'm going to run home as soon as i can to see if i can help. in the meantime i just emailed chris too i think he's home, and maybe he can see what's up?

hmmmm....

matt
--------------
Matt
New York City (yay!)
www.liquidware.org

AVRman

i have two Mega's that i dug out of my desk that seem to program correctly.

i'm using the Arduino 0016 version, which one are you using?

Severino

Hi... i just tested 6 of the new Megas in my book case and none of them will program with Arduino 15 or 16.
i'm going to test the rest and see if i can figure out why these Arduinos aren't working...

Mike
www.liquidware.com

Severino

update...
I just checked all of the Arduino Megas i have in my apartment...
The 3 that i first bought (in April) from the arduino team in italy worked fine.
The new 58 Arduino Megas (i bought in May) don't work at all... not a single will program!

I tested the ftdi usb circuitry and that checks out fine...

I just took out my AVR ISPMKII and i will test the fuse bits on the processor to see if they are different from my working Megas...
Mike
www.liquidware.com

retrolefty

Code: [Select]
I just took out my AVR ISPMKII and i will test the fuse bits on the processor to see if they are different from my working Megas...

Maybe they missed the step to burn the bootloader  ;)

Why don't you try and use your burner to try and reload the bootloader from the IDE.

Lefty

Severino

The fuse bits look fine...

Reading fuses address 0 to 2.. 0xFF, 0xDA, 0xFD .. OK!



now i will export the .hex file and compare the boot and flash to see if they are the same...
Mike
www.liquidware.com

Severino

well... it isn't that either...

I just compared the working .hex with the other .hex
the boots look identical



I also tried to use the known good .hex on the other broken Mega... but as expected it did nothing...

next i'm taking out my scope and giving some tests to the serial signals going into the Arduino...

I have a hunch that this is some kind of hardware issue...
Mike
www.liquidware.com

madworm

#25
Jun 12, 2009, 06:23 am Last Edit: Jun 12, 2009, 06:50 am by madworm Reason: 1
Maybe somebody used a bit too much solder paste on the fat chip. The pin pitch is similar to the FTDI chip though and that has worked before.
Or die DTR capacitor is borked, or the FTDI chip spits out inverted signals or... whatever.

Edit: So I was once right. That feels so good  :D

And it is easy to fix too.
• Upload doesn't work? Do a loop-back test.
• There's absolutely NO excuse for not having an ISP!
• Your AVR needs a brain surgery? Use the online FUSE calculator.
My projects: RGB LED matrix, RGB LED ring, various ATtiny gadgets...
• Microsoft is not the answer. It is the question, and the answer is NO!

Severino

yay!!!

i got it!

all the arduinos had an incorrect cap placed on them...



so i looked at the reset pulses on both sides of this capacitor to see if it was charging properly when the reset was sent from the ftdi chip...



this was in fact the case...
the ftdi chip was outputing the correct signal, yet the arduino wasn't being reset...

so i replaced it with a 100nF capacitor that i found lying around from the touchshields i built...

the only problem is that the 100nF i used was 0402 surface mount technology... but hey



and...

program!

and fixed

if you bought an Arduino from my website, give me a call on my cell phone (860  930   6480) or shoot me an e-mail ( mike.gionfriddo@gmail.com ) and i will mail you out a fixed MEGA as soon as possible...

sorry for the delay...
Mike
www.liquidware.com

Brian Avery

#27
Jun 12, 2009, 06:47 am Last Edit: Jun 12, 2009, 06:48 am by briansvgs Reason: 1
Mike,

Thanks for putting in all the time tonight to figure out what the problem was. Great customer service.

-Brian

retrolefty

Good troubleshooting, thanks for sharing your experiance.

Looking back now that we know the root cause, a test using the manual reset button while uploading a sketch would have worked and helped isolate the problem quicker and with less steps? Sorry, I was a hardware troubleshooter before retirement and can't help myself, I always tried to keep a lessons learned list on equipment I had to support.  ;)

Lefty

Severino

#29
Jun 12, 2009, 09:38 am Last Edit: Jun 12, 2009, 05:40 pm by Severino2020 Reason: 1
Ok... I just got done fixing and testing a bunch of them.
They are as good as new!

@Brian Avery
I will ship your package in the morning.

@Chankster
Your Arduino will also ship out tomorrow.

@retrolefty
Good call!
a hack that can be done is... pressing the reset button on the arduino after you click the upload button, and the arduino mega should accept the program....
Mike
www.liquidware.com

Go Up