Go Down

Topic: Arduino GSM Shield not responding? (Read 40495 times) previous topic - next topic

Haas11

Hi there,
Having the same problem with the GPRS Shield V2 icw UNO.

Stuck at "SMS Message Sender".

Tried editing the GSM class to retry connecting many times until it timesout, no succes.
Also tried several other workarounds, but no luck so far.

Anyone a solution yet?

Directly working with AT commands seems to work fine, although for my purposes I could really use the GSM functionality.

KingRamses

I'm trying to get my arduino GSM shield working with the example "Send SMS" code provided. However, when I upload and compile the program, the serial monitor displays "SMS Messages Sender" and nothing else occurs.

I got the exact same problem, i have try a LOT of diferent thing to make it work.

Does anybody have found a fix for this?

jgatvl

Same problem over here. Board says it's connected to network but stuck on this line. Same thing happens on other examples. First time GPRS shield user

cbryce20

Hi, I am using the Arduino Mega ADK, and I am able connect sometime. It seem I can only connect between 1 and 3 times per day. This is a problem for especially when I have to demo my project. And it also take very long to reconnect.

If you are using the same card that I am using, then make sure to follow the instruction on the Arduino site (jump the pin they stated and bend the pin so it don't make connection as they stated.

Then use one of the sample program from Arduino IDE to test the connection, that should work for you.

nixrobot

Hi !

I bought 2 weeks ago the GSM shield Rev2

I use it with the UNO board with the example code : "send SMS" , and I had the same behavior : Just the message "SMS Messages Sender"

It was due to the PIN number , I setted a wrong one. So I tried with my mobile phone and then I remembered the correct one and then confirmed it.

Then the arduino goes to the message "not connected"
I had always this message. I was disapointed.

But I found a small button named "power" on the shield. I push it few second
and then the status led switch on and the status led started blinking !!
Then I press the reset button to restart the soft, and it started to work !

I reached to send a SMS to my mobile phone !


On things that still doesn't work, is the serial, I cannot write characters on the serial console.
So I put my number and the text in constant in the code.

And I added a whiel(1); at the end of the loop, to avoid sending lot of same SMS.

Hope it help someone

piyushj1211

i have the same problem with send sms code if any one got it please reply

maxouv327

hi all,

same problem uno+antenova --> stuck in "not connected"

thx nixorbot i haven't even notice that i should press the power button to launch the program.
now status led is on whith but the led next to it is blinking indefinetly every 3 sec.

hope someone will post any advice.

++

maxouv327

hi,

It works for me.

I have arduino uno+antenova.

First my problem of connection was due to PIN code. I disabled it with a cellphone and then put into antenova.
Second i was unable to communicate withserial port like Nixrobot. It is due to console configuration you have to set "new line" in themenu at the bottom right.

Hope it helps.
++

rvrostaing

#23
Jun 14, 2015, 08:19 pm Last Edit: Jun 14, 2015, 08:25 pm by rvrostaing
Hi,
I have the arduino board (GSM shield V2 rev3) without antenna so i put a wifi antenna on it (same screw system).
Board is Arduino Uno Rev3.
IDe V1.6.4.
Power supply 12V and 1 Amp.
SIM card has no Pinnumber (desactivated) and work fine in a mobile phone.
SIM provider is ''free'' (french provider).
I do power up the shield.

Modem seems to work because example ''tools/ test modem'' works fine.

Test GPRS, Send SMS are not working... And i am totally stuck here !
I have the message ''SMS message sender'' and then nothing.

Any idea ?
Thanks for giving any tip !



impact

I had similar issues but I managed to solve it with activation of data transfer (with my provider and prepaid SIM you must activate data separately). I didn't think it matter as I wanted just SMS services... but it did ;)

rvrostaing

Thanks for your reply !
Data is activated by default by the provider.

Finaly in my case it was link to the antenna. There must be a GSM antenna... (sounds basic, yes...). Even more important if GSM connection is poor.

MrStoppable

I am having the same problems i have gone through many fixes for this issue but my serial console simply sits at "SMS Messages Sender".

Did the external antenna work for you rvrostaing?


rvrostaing

Yes it changes everything even without external power supply (still recommanded). Antenna is quite cheap .

MrStoppable

alright i am going to try that thank you so much!

David_Danieli

Hello!
 I normally use a power supply of 2 Amp, see the arduino gsm shield page.
I use an antenna (very important as rvrostaing said), I can initialize the gsm, receive and send sms. I don't use the Telefonica SIM but another Italian provider (Wind). I've the first version of the gsm shield. My problem is that the shield doesn't work and make the arduino uno go into tilt when there are more than ca. 15 sms on memory not read or deleted. If somebody has the same problem please answer.
Bye

Go Up