Go Down

Topic: Arduino GSM Shield not responding? (Read 41613 times) previous topic - next topic

Atia

Hi!
I seem to be having the same problem as everyone. Once I upload my code and open the serial monitor. The only thing that appears is "sms messages sender" and nothing happenes. I then tried with the example that comes with the arduino software and the same thing happens. I'm using the arduino uno with the gsm shield sim908.
Any help would be greatly appreciated.

dannable

The software provided with the IDE is for use with the official Arduino GSM/GPRS shield which uses the M10 chipset, not the SIM908.

There may be manufacturer specific commands in the libraries.

And given that the SIM908 has a built in GPS you need to communicate with it in a different way. Check the web site of the people who manufactured the shield / board.
Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

meuro

I just had the whole weekend the same problem as many people here, i was testing with two different sim cards (same operator, no pin code) and nothing... stuck at GSMaccess.begin()

then i tried another sim card, same operator but with pin code set (the only difference) and it started working!

Vajha_Harshitha

hello everyone. I am using Uno board and gsm mdule sim800. The gsm module is not getting connected.To check its connction i've used the example tst modem sketch and it shows up as not connected. But, I've given the cnnections as shown in the instructables. Can anyone give a fix to it pls.

youswagger

maybe its due to insufficient power supply. without using an external power supply, my serial monitor also display only ''SMS Messages Sender" and nothing else. i used an adapter of DC 12V and it works.

GDEL

Hallo,
I had the same problem as many people here on this forum ("SMS Message Sender" and then nothing more !)
After reading and trying a lot of things, I saw that the NET led on the GSM-shield (Original Arduino GSM Shield in combination with Arduino UNO) was blinking fast, what means that it is searching for a network !
As long as there is no network, no communication is possible with the shield via serial link.
I am in Europe (Belgium) and had a SIM-card from the Telenet-Provider, who is sharing its network with Base and covers not the whole country.
Today I bought an other card from the National Provider Proximus (Belgacom) and asked to disable the PIN-code so I had directly connection without to program the PIN-number in the sketch.
After installation (USB connection to PC and 12V external DC Power supply via the Arduino Jack), I used the example "GSM" from the IDE and loaded it to the Arduino board.
After a while the fast NET-led changed in a slow rhythm and I had connection with the Network !
Result : via the Serial Monitor : "Enter a mobile number" and "Enter SMS content" : The SMS was sent to my mobile and everything is OK now !
Conclusion : In my case the problem was caused by the service provider (and the PIN code I suppose).

Guy Delreux.

nardu0

#51
Nov 02, 2016, 03:43 pm Last Edit: Nov 03, 2016, 01:42 am by nardu0
Hi! Help me, please - my Sim900 which is attached to MEGA, does't answer via COM port's monitor. Jampers are established in SWserial. D7, D8 are attached with Rx1, Tx1. Sketch is usual:
Code: [Select]
unsigned char buffer[64];  // buffer array for data receive over serial port
int count=0;               // counter for buffer array

void setup()
{
   Serial1.begin(19200);
   Serial.begin(19200);
}

void loop()
{
   if (Serial1.available())
   {
     while(Serial1.available())
     {
       buffer[count++]=Serial1.read();
       if(count == 64)break;
     }
     Serial.write(buffer,count);
     clearBufferArray();
     count = 0;
   }
   if (Serial.available())
     Serial1.write(Serial.read());
}

void clearBufferArray()
{
   for (int i=0; i<count;i++)
   {
     buffer[i]=NULL;
   }
}

My construction is                    

I type "AT" but don't get any answer. Where I can find mistake?

nardu0


thanigai0329

I'm trying to get my arduino GSM shield working with the example "Send SMS" code provided. However, when I upload and compile the program, the serial monitor displays "SMS Messages Sender" and nothing else occurs.
I'm using Arduino uno and gsm sim9000A.after connection when I call to the sim in the gsm module it rings.I doesnot get what the code is wrong?

RSeuret

First, make sure that you have a SIM card inserted in the shield and that this card supports 2G as the shield, unfortunately doesn't work on 3G neither 4G. Then upload the script to the shield using the IDE, check on the tools that the right board has been selected and the right port of communication with the board also has been selected, otherwise the script won't be uploaded to the board. Once that this has been done open the serial monitor and wait for the connection between the shield and the network to be established. Here there is something to check, the shield has a power bottom next to the SIM card slot. press this bottom for a few seconds and wait until the status LED turn on and the NET LED starts blinking at this point you should see the following message: GSM initialized on the serial monitor and you are ready to go.

yuvarajd85

I am using an UNO board and GSM Shield 2 (antenova). I tried to run the SendSMS sketch and it just hangs on the code after the message "SMS Messages Sender" and after nothing happens.

I tried pushing and holding the power button until STATUS button starts blinking and then the reset button but nothing worked. Any idea what is the correct procedure to make this thing work. Any advice and guidance will help. Thanks.

mallison359

I use an Ardrino Mega with the Ardrino GSM 2 board. I had the same problem as everyone else. It started and then nothing happened. After a lot of reading I finally found the answer.

First thing you have to do is bend pin TWO out of the way and add a jumper between pin 2 on the GSM board and pin 10 on the GSM board. I am using an Apple IMAC no external power supply to GSM Board.

Switch on the power and you will see a small led light up next to the sim card then hold down the small switch next to the Sim Card and another small yellow led will light up. Next to that is another one that will flash rapidly and then flash slower.

I then sent the following program to the Ardrino Mega

#include <GSM.h>

#define PINNUMBER ""
#define remoteNum "07946000000"
#define txtMsg "Hello World"

GSM gsmAccess;
GSM_SMS sms;

void setup() {
 
  Serial.begin(9600);
  while (!Serial) {;}

  Serial.println("SMS Messages Sender");
 
  boolean notConnected = true;

  while (notConnected) {
    if (gsmAccess.begin(PINNUMBER) == GSM_READY) {
      notConnected = false;
    } else {
      Serial.println("Not connected");
      delay(1000);
    }
  }

  Serial.println("GSM initialized");
  Serial.println(remoteNum);
  Serial.println("SENDING");
  Serial.println();
  Serial.println("Message:");
  Serial.println(txtMsg);
 
  sms.beginSMS(remoteNum);
  sms.print(txtMsg);
  sms.endSMS();
 
  Serial.println("\nCOMPLETE!\n");



void loop() {;}

.......

Standard Version 1.6.6 Audrino Software. No other libraries.

This will send one message to the defined phone number.

You will see "SMS Messages Sender" come up on the serial monitor and then nothing seems to happen. This is because of the wait loop waiting for GSM READY. Just wait and it will eventually work and send one text message to your number.

Hope that helps someone ..

 
Can I check which provider you are using?

Go Up