Pages: [1]   Go Down
Author Topic: Program won't upload on second attempt  (Read 523 times)
0 Members and 1 Guest are viewing this topic.
The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino on tubes ??
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi there,

I built myself an Arduino Serial v2.0a
On the first attempt it worked fine (blink)
I tried to make some alteration on the program and tried again (different time on/off led).
Nothing !

message:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What does tat mean ??
Did I break something ?

 :-/
« Last Edit: June 16, 2010, 08:53:29 am by HoMeR » Logged

Boston, MA
Offline Offline
Edison Member
*
Karma: 0
Posts: 1024
wiblocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try pressing the reset button just before you start the download
and see if that works.

I have noticed on one of my machines that the USB /RTS that does the
reset trick works only the first time the port is used.

(* jcl *)

------------------------------------
www: http://www.wiblocks.com
twitter: http://twitter.com/wiblocks
blog: http://luciani.org
Logged


The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino on tubes ??
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Searching on the rest of the forum I found this: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1271833450
The same message !
Did I perhaps also burn (part of) my board (I used a 12 V powersupply); the 7805 got hot.....
Blink is stil running !? Does that mean is still works ??
Logged

Boston, MA
Offline Offline
Edison Member
*
Karma: 0
Posts: 1024
wiblocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you did not have any other hardware connected and blink still runs you are
probably OK. Running a 12V supply is not a good idea since as you add more
circuitry you will draw more current and the 7805 will run hotter.

Pressing and releasing the reset button immediately before the download
didn't work?

(* jcl *)
Logged


The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino on tubes ??
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The board is still at my workplace; I'm at home..... Haven't got time to test the resetbuttontrick.
Will try that tomorrow.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Greetings.

I have a similar problem with two new Duemilenova boards that I just received.  

 I am able to upload to a Duenilenova board that i have had for a couple of years...but not to these new boards. I am using Version 12 of the Environment.  Do I need new software to communicate with these new boards?  THANKS!
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 509
Posts: 31483
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I am using Version 12 of the Environment.

We are on version 18 now so an update is recommended. Especially as you are having trouble with new boards.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Turns out that the cure was to:  1. Load V18  and 2. Select the proper board from the Tools menu.

Thanks for your help!
Logged

The Netherlands
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino on tubes ??
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It worked !
Releasing the reset button as the text : "Binary sketch size: 896 bytes (of a 30720 byte maximum)"  appears in the screen does the trick.....

 smiley

Thanks !
Logged

Pages: [1]   Go Up
Jump to: