Go Down

Topic: Program won't upload on second attempt (Read 611 times) previous topic - next topic

HoMeR

Jun 16, 2010, 03:53 pm Last Edit: Jun 16, 2010, 03:53 pm by HoMeR Reason: 1
Hi there,

I built myself an Arduino Serial v2.0a
On the first attempt it worked fine (blink)
I tried to make some alteration on the program and tried again (different time on/off led).
Nothing !

message:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

What does tat mean ??
Did I break something ?

:-/

jluciani

Try pressing the reset button just before you start the download
and see if that works.

I have noticed on one of my machines that the USB /RTS that does the
reset trick works only the first time the port is used.

(* jcl *)

------------------------------------
www: http://www.wiblocks.com
twitter: http://twitter.com/wiblocks
blog: http://luciani.org

HoMeR

Searching on the rest of the forum I found this: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1271833450
The same message !
Did I perhaps also burn (part of) my board (I used a 12 V powersupply); the 7805 got hot.....
Blink is stil running !? Does that mean is still works ??

jluciani

If you did not have any other hardware connected and blink still runs you are
probably OK. Running a 12V supply is not a good idea since as you add more
circuitry you will draw more current and the 7805 will run hotter.

Pressing and releasing the reset button immediately before the download
didn't work?

(* jcl *)

HoMeR

The board is still at my workplace; I'm at home..... Haven't got time to test the resetbuttontrick.
Will try that tomorrow.

GreggM

Greetings.

I have a similar problem with two new Duemilenova boards that I just received.  

I am able to upload to a Duenilenova board that i have had for a couple of years...but not to these new boards. I am using Version 12 of the Environment.  Do I need new software to communicate with these new boards?  THANKS!

Grumpy_Mike

Quote
I am using Version 12 of the Environment.


We are on version 18 now so an update is recommended. Especially as you are having trouble with new boards.

GreggM

Turns out that the cure was to:  1. Load V18  and 2. Select the proper board from the Tools menu.

Thanks for your help!

HoMeR

It worked !
Releasing the reset button as the text : "Binary sketch size: 896 bytes (of a 30720 byte maximum)"  appears in the screen does the trick.....

:)

Thanks !

Go Up