Go Down

Topic: Can't Upgrade XBee Firmware (Read 3 times) previous topic - next topic

rappa

Hi,

I have two XBees that are working great (attached to XBee Shield), but I'm not able to upgrade the firmware (current firmware is 1083).  I followed instructions here http://itp.nyu.edu/~raf275/meshnetworking/XBee/XBee_firmware_upgrade.html but I get the following error:

Getting modem type....OK
Programming modem...Lost communication with modem
Write Parameters...Failed

The software is able to read/restore settings but not upgrade.  I'm wondering if this has anything to do with the USB to TTL FTDI conversion.  The tutorial uses RS232.  I tried upgrading to different versions but I always get the same error.

tsterk

I've just bought two XBEE shields.  Why are you upgrading the firmware - what new functionality will you receive?



rappa

Here's the firmware release history

http://www.digi.com/support/kbase/kbaseresultdetl.jsp?kb=168

I was looking for the automatic retries feature but in general I want to upgrade since apparently they've fixed a lot of bugs.

Adam Walker

Rappa,

Did you ever figure out the problem with upgrading the firmware? I have exactly the same error message. I am using an XBee shield on an Arduino board. The shield is set to USB and the Arduino chip has been removed as per various websites.

If you solved the problem I would love to know how you did it?

Thanks

mellis

You may have to use steps: one to write the firmware and then another to write the parameters.  After the firmware is written, try unchecking "always update firmware" and just do a write of the parameters.  You may also have to change the checkboxes on the main (leftmost) tab - depending on which kind of firmware you've uploaded (e.g. API mode or not).

Go Up