Go Down

Topic: My program won't upload (Read 2329 times) previous topic - next topic

Grumpy_Mike

Quote
and smoke started to rise from the atmega1280 chip


That clinches it, it's dead.  :(

The only cure is to replace the chip, which is a skilled job or buy a new one.
Next time get an arduino with a 326 chip that you can replace in a socket.

Peripheral_Hacker

well it's an arduino mega, i want a board that has lots of io pins, and more than one serial


necrokid

I get the same message, and the only power  I have hooked my Duemilanove is USB. I believe the problem is that the board is currently running a code when trying to upload. So is t here a way to clear the EEPROM with out uploading the EEPROM clear?

Peripheral_Hacker

I have decided to just get a more basic arduino from the makershed at make.

Erac

I also have an error of:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

When I press the reset button, the LED won't blink, but we tested the LED and it works (pin 13). The power indicator LED works fine.

My board is:

Freeduino Serial v2.0 board KIT Arduino Duemilanove Compatible
ATmega328P microcontroller and requires Arduino IDE version 0013

External power source: 9vdc 500ma

I got the capacitors mixed up at first and soldered them in the wrong positions; did that damage the ATmega328P IC?

PLS HELP...

Mr.A

My board had the same problem that yours Erac.  Error code:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Used hours and hours and the problem atleast with me, the FTDI usb driver didn't work right so i reinstalled it carefully following the instructions, and now it works fine

Erac

@MR A and to all:

When you plugged the external power source and pressed the reset button, did the LED in pin 13 blink? Mine didn't

Maybe a hardware problem? and another thing, I had mixed up the capacitors and soldered them in the wrong places and plugged the 9vdc source, did that damage the IC? board?

Pls help...

Mr.A

The Pin13 LED did blink so it wasnt a hardwarefail in my case but it's strange that i got the same error code.

What kind of capacitor did you solder in ? some are polarized and can probably will die when no correct pluged in. It should not ruin you board. Just solder a new capacitor the right way in and try it out.

Erac

@Mr. A

If the LED at pin 13 didn't blink when the reset button is pressed then are we looking at a defective AT mega IC here? OR is it an indication that it has no boot loader in it?

Thanks

Peripheral_Hacker

this topic is no longer valid by the creator of this topic (me).
It still can be used for the same general purpose if need be.

Peripheral_Hacker

@Mr.A

If I had known to reinstall the FTDI drivers, I might have an Arduino Mega, and an Arudino Duemilanove.  ;D

Mr.A

#27
Jul 20, 2010, 02:42 pm Last Edit: Jul 21, 2010, 12:47 am by Melstream Reason: 1
@Erac: im no arduino expert but from what i have read, no blink in led pin 13 means no boot loader, but ofcourse it could be a broken Atmega chip to.

@Peripheral_hacker: It's not sure that it was the problem with your aruino, from what i can see that error code is that the arduino ide can not comunticate with the arduino. The FTDI driver is one reason why it may not comunicate.

graymalkin

Compressed air on the circuits try again? It might be a but of gunk shorting some ions on the 1280 perhaps?

Peripheral_Hacker

well, as I said earlier in this topic, I just decided to get an arduino duemilnove, because i fried the atmega chip in the arduino mega by accident - i connected a 12v power supply to the ac plug, and whilst trying to get more power to a motor, i connected the 5v and vin pins together. i kind of wish that i had a high-power diode then. but since i fried the chip in the mega, i am sooo going to be more careful.  ;)

Go Up