Go Down

Topic: Running before walking? (Read 629 times) previous topic - next topic

Teebor

I built an arduino from scratch using a guide I found on the ITP Physical Computing website (can't post a link as the forum will not allow it)

I also bought a USB to Serial TTL Cable from coolcomponents.co.uk

I completed the build and checked all the connections which showed as fine, I checked the power supply board as being ok and then I fitted the pre-programmed ATmega 328 with arduino bootloader.  Powered it on and it the LED starts flashing immediately, on and off steady as I would hope to see with the blink program.

So I tried to upload a new sketch and I get the following error message:

Binary sketch size: 914 bytes (of a 30720 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51a

The serial device installs as com 6 and I have set it to 19200 in the preferences file.  I'm trying to upload the blink no delay sketch as a test.


So I'm thinking maybe i'm doing something wrong as even using different timings for pressing the reset switch isn't working so using spares I built the parallel programmer (not ideal but I have no other programmer to hand right now)

I then replaced the pre-programmed ATmega 328 with a blank one (which I originally planned to program using the first when it was working)
However when I try to program it I get:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
avrdude: Yikes!  Invalid device signature.
avrdude: Expected signature for ATMEGA328P is 1E 95 0F
avrdude: AVR device not responding
***failed;  
avrdude: verification error, first mismatch at byte 0x0000
        0x3f != 0x00
avrdude: verification error; content mismatch

Looking these up on Google I have tried a few things like changes in the Windows XP registry for the parallel port, making sure no programs are polling serial/parallel port and some other stuff

I have tried changing the bootloader that is being uploaded to 168/328/deumilanove/lillypad etc but no luck.


AWOL

Quote
I then replaced the pre-programmed ATmega 328 with a blank one

A really blank one?

You need to write the bootloader into it.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Teebor

Yes, But I should have worded my post better, the second error I get is when trying to burn the bootloader with the parallel programmer

liudr

Are you sure you chose under tools->board the right board (duemilanove with 382)?
Also a picture will be very helpful.

Osgeld

parallel programmers are hit and miss since noone really sticks to the standards anymore

you can mod the arduino so that you can load a bootloader via the ftdi chip by bitbanging it from a pc (its a menu option in arduino) or if you have the 16mhz crystal n caps you can use your arduino as a avrisp to program a second chip on a breadboard
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Teebor

Definetly chose the right board, no picture but here is the guide I followed http://itp.nyu.edu/physcomp/Tutorials/ArduinoBreadboard

I've downloaded the latest Arduino 0018 but I can't see the bitbang option... I will do some searching around though and have a look as I would feel more comfortable using the ftdi rather then the parallel programmer even though I did find the instructions to build that on here.

I orignally planned to use the pre-programmed 328 as an avrisp through the arduin 0018 software but that doesn't seem to be working as I am having problems talking to the pre-programmed 328 making me think it was programmed with blink and not the proper bootloader?

deSilva

#6
Aug 15, 2010, 11:41 pm Last Edit: Aug 15, 2010, 11:42 pm by mpeuser Reason: 1
As you say you bought "some USB/TTL cable" there is most likely no autoreset involved. This is something also not addressed in the oherwise excellent tutorial from ITP. As the 168/328 bootloader has a very short time window there is only one option to press the reset key for the loading: immediately after the line
"Binary sketch size....."
is displayed.

Teebor

Thank you all very much for all your help everyone

I am now able to program my arduino through the ftdi cable as normal

Because of your posts I started questioning everything I've done so far and I found 1 incorrectly placed wire on the ftdi inputs, it was still correctly drawing voltage but not from the right source. I changed that and now I was able to program it so I will now be trying to program the blank 328 I have :D

YAY I'm so happy, thanks again guys

On to the next project turning the arduino in to a small networked rss news feeder  :)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy