Go Down

Topic: Strange readings from analog pins using potmeter (Read 401 times) previous topic - next topic

Stigern

Sep 04, 2010, 11:58 am Last Edit: Sep 04, 2010, 12:22 pm by Stigern Reason: 1
Hi

I've just took out my arduino boards again, and I tought I should start with just the easy Knob tutorial to refresh my arduino skills :P

Anyhow, I've noticed the servo didn't respond like it should. So I put
a serial.print on the reading just to see the value. And it's stuck around 250-300, no matter how I adjust the pot.

So first I changed to another 10k potmeter, same there. Then tried another arduino board. Same there. Also tried changing to another analog pin, but same thing there...

Then I tried the good old Arduino Diecemila(or how its written). Then it read the values perfectly!

Why wont my Picos, Nanos, Boarduino, BareBonesBoard show the correct value from 0-1023 when adjusting the pot? And only the old
diecemila. It's very strange, and I'm very confused right now ....

Cause I wanted the Modified Pico or some other board like the Boarduino to control some servos.

Only the good old arduino diecemila. Thats strange.

I use 5+ and GND for the outer pins, then the center pin I got on analog2.

Picture of the simple wiering on a Modified Pico



Uploaded with ImageShack.us

White is center pin, red & black are gnd and 5v
I'm from Norway!

AWOL

#1
Sep 04, 2010, 12:49 pm Last Edit: Sep 04, 2010, 12:50 pm by AWOL Reason: 1
What are those unconnected pins across the top of the board labelled "A0", "A1" etc?
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Stigern

#2
Sep 04, 2010, 12:52 pm Last Edit: Sep 04, 2010, 12:52 pm by Stigern Reason: 1
HAHA!

My god, how can I be so stupid :P

I blame the in-activity lately, it's like 5 months since I last used my arduino boards.

thanks!

Works fine now :P
I'm from Norway!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy