Go Down

Topic: Uno USB invisible to OS X (Read 4 times) previous topic - next topic

scruss

[font=Georgia]Just got my Uno after finding semi-permanent projects for two previous Duemilanoves. Upgraded to Arduino 0020. After rebooting, and power cycling the Uno, there's still no serial port for the Uno.

The board is noted under Linux, which reports an unknown device with ID 2341:0001. On my MacBook (10.6.4), System Profiler lists:
Code: [Select]

Communication Device:

 Product ID:      0x0001
 Vendor ID:      0x2341
 Version:       0.00
 Speed:      Up to 12 Mb/sec
 Location ID:      0x24110000
 Current Available (mA):      500
 Current Required (mA):      Unknown (Device has not been configured)

There are no /dev/tty* or /dev/cu* devices that correspond to the device.

Please let me know what I'm doing wrong.[/font]

mariod

I have a similar problem with my new Uno board.

I'm using Ubuntu 10.4 32bit and only the ttyS0 looks up under the IDE.

After connecting the Uno to the Laptop this is the message of dmesg:
Code: [Select]
[  142.968435] lib80211_crypt: registered algorithm 'CCMP'
[  143.205626] padlock: VIA PadLock not detected.
[  143.240799] lib80211_crypt: registered algorithm 'TKIP'
[  172.148099] usb 4-1: new full speed USB device using uhci_hcd and address 2
[  172.350490] usb 4-1: configuration #1 chosen from 1 choice
[  172.601905] cdc_acm 4-1:1.0: ttyACM0: USB ACM device
[  172.609577] usbcore: registered new interface driver cdc_acm
[  172.609585] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters


I tried to link the ttyACM0 to ttyUSB0 and now the device shows up, but I'm not able to program the board:
Code: [Select]
Binary sketch size: 960 bytes (of a 30720 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0xf9
avrdude: stk500_recv(): programmer is not responding


Hope anybody can help...

James C4S

I am also running 10.6.4.

Whenever I connected the UNO, I would get a message about "New network interface has been connected but not configured."  I kept hitting cancel or ignoring it.  Finally I clicked configure and was brought to the Network panel of System Preferences.  Clicked "Apply" and closed preferences.

After that my profiler says then when Uno is connected:
Code: [Select]

Arduino Uno:

 Product ID:      0x0001
 Vendor ID:      0x2341
 Version:       0.00
 Serial Number:      649383233313512172C0
 Speed:      Up to 12 Mb/sec
 Manufacturer:      Arduino (www.arduino.cc)
 Location ID:      0xfd340000
 Current Available (mA):      500
 Current Required (mA):      100


And a new /dev/tty.usbmodemXXXXXX device shows up (with a /dev/cu counterpart.)

You might re-connect it and check System Preferences -> Network to see if you have a Arduino Uno interface listed.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

westfw

Note that the the Arduino Uno shows up on Macs as a /dev/tty.usbmodemXXXX instead of a /dev/tty.usbserial-YYYYYY as it did with the FTDI-based Arduinos.

mellis

scruss: weird.  The correct USB VID and PID are showing up, which means that the ATmega8U2 on the Uno should be running the right firmware (that's what supplies those IDs).  I don't know why you'd get them, but not the "Arduino Uno" name - both should be in the same USB metadata.

Do you have an AVR ISP?  You could trying reburning the firmware onto the ATmega8U2 (it comes in the Contents/Resources/Java/hardware/arduino/firmwares/ directory, with instructions in the readme).  

What do you see in the Console application when you plug in the board?  I get:

10/2/10 4:54:49 PM      kernel      AppleUSBCDCACMData: Version number - 4.0.1, Input buffers 8, Output buffers 16
10/2/10 4:57:07 PM      kernel      AppleUSBCDCACMData: Version number - 4.0.1, Input buffers 8, Output buffers 16

Go Up