Pages: [1]   Go Down
Author Topic: Arduino + RFM12 - Does not work  (Read 1144 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
we designed a board with an arduino, a rgb led and a rfm12 868mhz (wireless radio modules from HopeRF http://www.hoperf.com/rf_fsk/rfm12.htm). Here is our design: http://img.skitch.com/20100914-f18mpq3uy53guugujgka1yj2id.jpg.

We use the rf12 lib from http://cafe.jeelabs.net/sw/library_-_rf12/ and the requiered path lib for the correct pins. We has nearly the same connections like in this picture http://farm4.static.flickr.com/3337/3296687815_007f613b6b_o.png execept one wire. But we changed the pin in the rf12 paths file to the right one.

After compiling and uploading to the board the serial monitor tells us, that our example gives the right output.
But we can't send/receive data. We changed for every board the note-id and we checked the data on the connector with an oscillograph, we think its everythink ok. But we cant send/receive data. We also selected the right mhz from the lib. Any idea? Is there a design error?
Thank you very much
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This was also cross posted on the JeeLabs discussion forum - http://talk.jeelabs.net/topic/493
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't know if that can help but I have interfaced an arduino pro mini with an rfm12b.
The only problem will be that running at 8MHz, the SPI cannot reach the same data rate as in the 16MHz case.
Logged

Pages: [1]   Go Up
Jump to: