Pages: [1]   Go Down
Author Topic: Arduino Duemilanove 328 plus ENC28J60 = no serial  (Read 1519 times)
0 Members and 1 Guest are viewing this topic.
Sydney, Australia
Offline Offline
Full Member
***
Karma: 3
Posts: 230
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all,

I bought one of the cheap ENC28J60-based Ethernet shields and whenever I connect it to my Duemilanove I lose serial comms completely back to my Mac. The serial port literally disappears from the Tools/Serial Port menu. Meaning I can't upload new SW to the Duemilanove without disconnecting, but more importantly I can't debug by sending serial commands.

It's this last point that's killing me because I'm finding even for a very simple web server app the combination of Duemilanove + ENC28J60 being very very unstable. It might stay up for a few minutes and happily reply to requests - and then it will stop responding. I can't ping it and page requests eventually time out. However the HW lights on the ENC28J60 blink to show traffic. Hitting the reset button brings it back again.

Has anyone else seen this issue with the serial comms? It's annoying to detach the shield for each app upload, but even worse is no debugging ability.

If else fails I'll drop this ENC28J60 in the bin and buy a proper ethernet shield...


Cheers,
Gavin.
Logged

Is life really that serious...??!

Manchester (England England)
Online Online
Brattain Member
*****
Karma: 627
Posts: 34234
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Was it one of these:-
http://www.nuelectronics.com/estore/index.php?main_page=project_eth
If so I found them to work without disabling the serial connector.
Have you tried just connecting the shield to the arduino and not the Ethernet lead? Does it only disconnect the serial port when the Ethernet lead is connected up?
Logged

Sydney, Australia
Offline Offline
Full Member
***
Karma: 3
Posts: 230
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Very similar. This is the exact one I got from ebay.



The serial issue isn't dependent on inserting the ethernet cable. As soon as I attach the shield (with Arduino powered off - ie not connected to USB power) and then re-connect it all to my Mac the serial port is no longer available.


Cheers,
Logged

Is life really that serious...??!

Sydney, Australia
Offline Offline
Full Member
***
Karma: 3
Posts: 230
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

For sale: ENC28J60-based ethernet shield. Barely used. Barely works. Offers accepted.

 :smiley
Logged

Is life really that serious...??!

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Anyone else have any answers to this. I have the exact same issue.  Arduino Duemilanove 168 with the same ethernetshield ENC28J60 loses the serial connection in the exact same way.  Arduino alone works no issues. Add the shield, plug it into PC, (multiple windows machines tried), I get the USB device has malfunctioned, and the FDTI drivers do not pick it up and assign a port.

I am using only the usb power, possibly an issue with needing external power as well?  Not sure, I am new to the micro controllers, more of a software designer background.
Any help is appreciated,
Thanks.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have found that these boards do need external power to run, usb is not satisfactory..
Logged

Pages: [1]   Go Up
Jump to: