Pages: [1]   Go Down
Author Topic: Problem (Ard + Ethernet + SD)  (Read 486 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Good morning,

Long time ago, i wanted to start with Arduino... nowadays i've been working for a shot time with it.

Now, I have a big  problem that I do not  know how to resolve it,  It's possible
that someone had this problem in the past, and it's already solved.

I need to create a log file  in the SD card, as CSV files,  simulating entrances
with in and out direction (those entrances are today working with buttons),  and
at the same time, the possibility to check this files from a web browser

Everything is already  working, but... no  everything... My problem  is that the
code that writes log file, stop to write, and i can not find any patron why this
occurs (file size,  time, ...) But  at the same,  Arduine lets me  read the file
with web browser, so I think that the board is not problem.

An example of those files are:

LOGGER11.CSV   2268  ?        LOGGER12.CSV  585   ?
LOGGER13.CSV   90   ?        LOGGER14.CSV  2409   ?        LOGGER15.CSV   654  ?
LOGGER16.CSV 3355 ?      LOGGER17.CSV 447

Hardware
Arduino: Duemilanove
ethernet shield:
http://arduino.cc/en/Main/ArduinoEthernetShield
clock:
http://www.bricogeek.com/shop/56-placa-reloj-rtc-ds1307.html

lib:
SD – sdfatlib - http://code.google.com/p/sdfatlib/
Ethernet – La de Arduino
Reloj – Wire (Arduino)

I have disconnected everything but clock and ethernet shield, to test if the problem is the power consum, but it's not. Plus, Ethernet shield is too hot when Arduino is working, is this a normal behaviour?

I have uploaded the code to Megaupload (http://www.megaupload.com/?d=R3K343F5), if it's possible you that someone take a look and could help me

Thank you very much in advanced for your help.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 10
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here comes the fun, if approached my face to shield ethernet and puff, the log continues to grow until I stop .. The file then can have a few Mb

Then I thought that clearly would be a heat problem, so I got a big fan blowing all the time, and the size of the logs were still less than a MB (and W5100 temperature was very low with this fan)

It's just that the board is kidding me?  :-[

Logged

Pages: [1]   Go Up
Jump to: