Pages: [1]   Go Down
Author Topic: NKC RGB LCD shield causes disconnection  (Read 889 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Howdy!  I'm using the Duemilanove with an atmega328, and I've recently assembled NKC Electronics' 'RGB LCD Shield for Arduino.'  Go Team Phil!  But wait!  There's more!  When I plug the darn thing into my arduino, the arduino suffers a total communication loss with the PC.  To the point that it even loses power.  I've checked my connections again, and checked my assembly vs. assembly guide.  Then I had my brother check everything over (he's better at this than me).

So, basically what I'm wondering is if anyone else has tried using this shield, and if they've had the same problem, or if it worked.  And if it didn't work, then whether they found a resolution.

Thanks!
-Phil
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 505
Posts: 31332
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It is possible that your supply is not able to provide the current. Have you tried using an external power supply?
Logged

Oslo, Norway
Offline Offline
Full Member
***
Karma: 6
Posts: 126
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I guess you are refering to http://www.nkcelectronics.com/rgb-lcd-shield-for-arduino-65k-color-k65.html.

I have not had any problems with mine....

/Henning
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 34
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am having the same problem. When I plug the LCD Shield, the arduino powered off.

Edited:

After doing some test, I figure it out that there is a short circuit between the VCC pin and GND pin. But I cant found where is the short circuit. All the solder points are OK. No apparent short circuit on the solder points.

Any help will be apreciate.

TY
« Last Edit: October 25, 2010, 08:18:14 pm by otaviousp » Logged

USA
Offline Offline
Sr. Member
****
Karma: 0
Posts: 452
Freeduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

@WestNQ: can you send me hi-res pictures of the top and bottom of the board to support at nkcelectronics dot com?

Thanks
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 34
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have just send an email to you(NKC suport). Hope the picture can help.

TY
Logged

USA
Offline Offline
Sr. Member
****
Karma: 0
Posts: 452
Freeduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I saw the pictures... the problem is probably below the LCD.  The tiny thin PCB that is used to attach the LCD to the board does not tolerate well the huge solder pieces that you have... i am assuming, based on the soldering of the other through hole components.  I will reply to your email with some follow-up information.  I will also include in the assembly guide page to be careful with the soldering of the LCD to the board, and check for any shorts before continuing the assembly.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 34
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was thinking that this could happen, but before soldering the LCD on the Shield, I checked if there were any short circuit. I will re-weld to see if it resolves.

thanks
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the same problem, looked over all my connections, even tried the shield without the LCD connected and still have issues with the arduino not showing power.
Edit: after doing some more testing, it looks like the problem happens when pin 2 of the icsp header is connected. I'm not good enough with schematics to trace that back to where my problem is, but all my connections seem to be ok.
« Last Edit: November 07, 2010, 03:47:09 pm by munchmo » Logged

Pages: [1]   Go Up
Jump to: