Go Down

Topic: avrdude content mismatch: Linux, ATMEGA328 (Read 5 times) previous topic - next topic

michael shiloh

Platform: Ubuntu Linux
IDE rev: 13 alpha
Arduino: Duemilanove with ATMEGA328

Error:
avrdude: verification error, first mismatch at byte 0x0006
       0x8d != 0x7d
avrdude: verification error; content mismatch

But there are two weird things:

1. It worked OK at first, through about a dozen downloads, then suddenly started exhibiting this problem.

2. A different board of the same revision is showing no problems when
uploaded from a Windows computer running rev 14. However, my board, shows the same problem on Windows.

Is it possible I've corrupted the boot loader?

There has been a long thread on the forums about an avrdude protocol
error, and I think I may have seen this occur a few times. In the
forums, there are many proposed explanations and fixes. Most assume
problems with the Windows port (not my problem), but some suggest manual reset before upload. This did not help me.

At first I suspected a problem with the Linux version 13 alpha, but now
I'm not so sure.

Suggestions?


mellis

It sounds like there's flakey communication somewhere, not a fundamental problem in the setup.  Is the error message always exactly the same (i.e. the same byte number)?

I'm guessing there's a loose solder job somewhere on the board.  You should be able to get it replaced by the distributor that you bought it from.

michael shiloh


michael shiloh

Well, it's been a long time but I finally bought and built a USBTinyISP. I've used it to try to reprogram the boot loader, and guess what: I get the same error:

avrdude: verification error, first mismatch at byte 0x0000
        0x3f != 0x0f
avrdude: verification error; content mismatch

It's always the same error: same address, same byte value.

I'm using the USBTinyISP to power the Arduino.

Any ideas?

Michael

trialex

Are you 200% sure you've got the right chip selected in the Tools -> Board menu?

If you bought the ATmega328 separately remember the '328 is not the same as the '328P

Go Up