Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x00 (Read 209 times) previous topic - next topic

ewwwzy

Thanx to those that posted previously. Im a newbie. I just set everything up for the first time and ran the example program "Blink".

Led flashed for 1/2 sec on about 3 secs off. Also got these error messages

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

tried suggestions in the previous posts and found that I had the wrong com port selected.  
Sorted that out, shut down 0017 and restarted it, uploaded to the chip and it now works as it should.  Im using Windows XP, Haceduino Atmega168-20PU.


Thephen

#16
Oct 24, 2009, 01:17 am Last Edit: Oct 25, 2009, 12:36 am by thephen Reason: 1
I just had the same error pop-up too, and the OP's solution worked for me.

For the sake of Google helping another newbie:
I'm using a MacBook Pro MBP running Snow Leopard. I connected my ATMEGA 328 via USB.

I got the avrdude: stk500_getsync(): not in sync error while uploading a sketch to the Duemilanove.

The fix was to Quit the Arduino IDE; unplug everything from the Duemilanove (protoboard, usb, power, etc.); plug in the USB cable between the laptop and the Duemilanove; and re-upload the sketch.

I then unpowered the Duemilanove, re-patched my circuits/jumpers/what-not, and I'm running happily.

I need to go back to the troubleshooting and getting started material here and review the most optimal procedure for keep the Duemilanove safe while moving between sketched and hardware set-ups. Perhaps I got ahead of myself earlier, while I was experiencing the error.

I'm wondering it would have been sufficient to just shutdown the Ardunio IDE and re-plug the USB cable (at the laptop end) to give the USB machinery a chance to get straightened out. Hmmm. :-?

(Update: Corrected Duemilanove spelling)

Mistri

I was having the same problem.  In my case it turned out to be communication was going to the wrong port.

In the Arduino environment, go to Tools, then Serial Port and made sure the correct COM port is selected. It should match the port that the computer has assigned to the board (which you can find by control panel > system > hardware > device manager>ports) - it is USB Serial Port

aventgps

few days ago i was testing my programing skills with arduino, windows xp 32, arduino s3v3 with armega328 and arduino IDE 0017.

i got the avrdude error.......... this happened after making a lot of successfull uploads.........

i searched, googled. looked everywhere, tried everything.
nothing worked.....    then i made myself a parallel programer (without the resistors, i was in a hurry) changed my computer, (my new one does not have parallel port), and burned the bootloader to the chip.....
it worked very good, the same day ordered another s3v3 with an extra atmega328 chip........ and again burned the new chip with the bootloader........ cero problems.......

if you want, after making all the testing  you see on the forums, if nothing works, do as i did........ also recomended to have a spare burned chip, just in case........

Thephen

#19
Oct 25, 2009, 04:24 am Last Edit: Oct 25, 2009, 04:30 am by thephen Reason: 1
AHA!

I have worked my version of this problem a bit further and I have uncovered what seems to be the root-cause of my problem.

My sketch & hardware set-up uses digital pins 0-5 to connect a Jimmie P Rodger's Open Heart LED kit. http://www.jimmieprodgers.com/openheart

Whenever I attempt to upload a sketch while the kit is connected to my Duemilanove, I get some transmission problems. I believe this is due to the digital pin 0 & 1 being re-purposed as TX and RX pins during the upload process.

The fix:
I adjusted things so that I am not using pin 0 & 1 any longer (I shifted things to use pins 2-7), and that was cured my communication problem.

I can now upload sketch adjustments over & over without any problems, unplugging, re-starts or otherwise.

The following thread mentions this problem. It mentions that use of the USB and soft serial facility precludes the use of pin 0 & 1: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1238095159

Go Up