Go Down

Topic: Solarbotics Ardweeny (Read 3059 times) previous topic - next topic

mburkit

Hello,

First, I must say I am new to using the Arduino.  

As my first unit, I recently purchased one of Solarbotics' Ardweeny units with the ATmega328 chip along with the sparkfun.com 5v basic FTDI breakout board.  

I am using Windows XP and have the latest FTDI drivers installed.  When I plug the unit into my PC, the Pin 13 LED flashes a few times then goes out.  It will flash once when I hit the reset button.  Wtih my multimeter, I am getting a steady 5v from the "+" and "GND" pins on the chip, while plugged in.

I also tried to upload the "Blink" sketchbook onto my unit, using the Arduino 0017 IDE and I get this error codes:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

Which, from what I read means I'm not getting any communication between the chip and the IDE program.

So my question is, what do you think could be the issue? Did I do a crappy job soldering the board that sits on top of the chip? If so, what do you think could be the issue? Or maybe it's a software issue?

If you need anymore information to help me, please ask.

Anyway, thanks for the assist!

n00b

Ok lets start simple, got the chip and the FTDI Basic Breakout the right way round?

mburkit

Yes, I have the chip lined up correctly with the circuit board on top of it and the FTDI Breakout Board plugged in correctly.  

I went down the list on the Troubleshooting page. . .

I have the correct board and com port picked as well.  

I'm debating if I have a cold solder point somewhere.  I need to pick up a new de-soldering wick tomorrow.  I'm just trying to see if someone has experienced this before or if I'm just missing something stupidly obvious.

TchnclFl

#3
Jan 19, 2010, 04:44 am Last Edit: Jan 19, 2010, 04:44 am by Tchnclfl Reason: 1
Another simple question:  Are you sure that the pinout from the breakout board is the same as the Ardweeny?

mburkit

On Solarbotics' page for the Ardweeny, at the bottom they have this:

Quote
Requires external USB-to-TTL FTDI-type cable or adapter, like the SparkFun Simple FTDI Adapter (parts 50512 or 50510)


And then have the hyperlinks for those two models.  I have the 50512 model.  So I'm assuming its correct.

TchnclFl

You may want to double check it anyways.

n00b

I know Sparkfun do:

FTDI Basic Breakout - 5V
FTDI Basic Breakout - 3.5V

My be worth looking into what one you have, or if it make any difference on that board?

n00b

#7
Jan 19, 2010, 05:19 am Last Edit: Jan 19, 2010, 05:35 am by n00b Reason: 1
Quote
One of the nice features of this board is a jumper on the back of the board that allows the board to be configured to either 3.3V or 5V (both power output and IO level). This board ship default to 5V, but you can cut the default trace and add a solder jumper if you need to switch to 3.3V.


if you have there 50512 (FTDI Basic Breakout - 5V) then that is fine, and this is not your issue.

cold solder on the board im going for.

mburkit

Mine looks exactly like this one, from the .pdf manual for the ardweeny:



I had also contacted solarbotics before I made the purchase to make sure I was getting the right breakout board.  I purchased the 5v one.  And my multimeter picks up a steady 5v's from the "+" and "GND" on the chip when its plugged in.

mburkit

So I resoldered the ATmega328 chip and this is what happens when I plug the sucker in.  

I plug it in, and the TX and RX lights on the breakout board flash a few times. The pin 13 LED will blink about 10-15 times then stop.  The pin 13 LED will also blink once if I hit the reset button.

When I try to upload the "Blink" sketch, I still get this code:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

Could it be the auto-reset is not working?

big trumpet

Hello,

maybe you can measure the voltages directly from the pins of the ATmega,

VCC,GND,AVCC,AGND. This will help to see if the soldering is fine or not.

I notice from their photos,  3.3V FTDI breakout cable seems to be different from the 5V cable. The TXI and RXO pins are reversed. So pls check the breakout pins are really connecting to TXD and RXD of Atmega, and not the other way round.

You may check against the schematic of Arduino Duemilanove for reference

http://arduino.cc/en/uploads/Main/arduino-duemilanove-schematic.pdf

Joseph

buchacho

#11
Jan 21, 2010, 04:48 am Last Edit: Jan 21, 2010, 04:49 am by buchacho Reason: 1
Maybe it is not an ATmega 328?  I was going to buy one the other day but they are now shipping with the ATmega168.

mburkit

Well, the chip says its a 328 on it but I also tried different board settings and get the same thing.

As for testing the pins on the ATmega, I'll try to do it tomorrow if I have time.  I've been busy all today and probably till the weekend now . . .

CaptainObvious

You could just use jumpers from the TX and RX on the FTDI breakout directly to digital 0 (rx) and digital 1 (tx). (and ground of course) You'll have to manually reset, but that just rules the auto-reset issue. This *should* rule out any hardware mixups as well.

Also, like stated below: do make sure you try the opposite of what you tried with the RX and TX.. I know that some boards label them funny.. just make sure you try at least once to switch the two.


Also maybe you could post pictures of everything, top and bottom. May be able to answer a few more questions with a visual.

When I soldered my first Arduino onto a protoboard, it took me like an hour to figure out why it wasn't working.. I checked every solder joint, resoldered some.. pulled the chip off, checked it and it worked..
Turns out I had the button wired wrong.. it was grounded.. which is why I couldn't upload. I just mixed up the button connections.

Check for the simple things!:)

Boz

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

A baud rate discrepancy could  kick that error, is the ardweeny running the same rate that is set in config, IE If the config is set at 19200 and the board is running at 57600 ( or vice versa ) it wouldnt communicate right.

Look for the setting in the boards.txt file

Just a thought

Go Up