Go Down

Topic: ATMega328P broken? (Read 1 time) previous topic - next topic


Heya Guys,

I wanted to upload a sketch to my arduino Duemilanove (DFRduino version)

It worked fine for a few months, but now i'm getting this error while trying to upload a sketch :

avrdude: stk500_read_sig_bytes(): (a) protocol error, expect=0x10, resp=0x09
avrdude: error reading signature data for part "ATMEGA328P", rc=-3
avrdude: error reading signature data, rc=-1

The chip itself is probably broken, but i'm not sure, can u guys help me ?

Thanks in advance!


Have you tried reinstalling the boot loader on the chip? It may have gotten corrupted.


Hey, thanks for ur fast reply.

I wanted to try that, but i don't know wich one i have to choose. Any ideas ?



I don't have the program in front of me to read the exact menu names, but if you look at the options, you will find one that says Duemilanove with the m328 chip.  I'm not sure what the DFRduino version is, but I expect it will still use the standard m328 bootloader.

It might help to go to the hardware folder (windows), then to the bootloader folder and look at the different hex files - from the names you should be able to figure it out.

Good luck and have FUN!!

Ken H>


Thanks, i tried that but no response tho.. Any other options ? Buying an new pre burned loader ?


You selected the right download COM port from the Arduino environment menu?


Hey, neyluzz. Did you handle that problem??? If you reply the question I will be appreciated :). Thanks from now.


Hi Addis,

I haven't looked so far, but i will look up for my arduino and test it. I'll let you know!

Kind regards,

Niels 8-)

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131